summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorlethalman <lucabru@src.gnome.org>2015-09-18 16:36:30 +0200
committerlethalman <lucabru@src.gnome.org>2015-09-18 16:36:30 +0200
commitb7319c79a625a4e3fb08ce87fa599ad6a9f9c5af (patch)
tree38cc2eddf01371a16501d1a050e63d5ce8cc12e9 /pkgs/development
parentd6fd3c4270de9c0c2fcce53cfc4903e916d9a4c2 (diff)
parentd3f5461aef15ee94a0b01d7c93c3dfd55e266e02 (diff)
downloadnixlib-b7319c79a625a4e3fb08ce87fa599ad6a9f9c5af.tar
nixlib-b7319c79a625a4e3fb08ce87fa599ad6a9f9c5af.tar.gz
nixlib-b7319c79a625a4e3fb08ce87fa599ad6a9f9c5af.tar.bz2
nixlib-b7319c79a625a4e3fb08ce87fa599ad6a9f9c5af.tar.lz
nixlib-b7319c79a625a4e3fb08ce87fa599ad6a9f9c5af.tar.xz
nixlib-b7319c79a625a4e3fb08ce87fa599ad6a9f9c5af.tar.zst
nixlib-b7319c79a625a4e3fb08ce87fa599ad6a9f9c5af.zip
Merge pull request #9842 from chetant/libwebsockets-1.4
Add Libwebsockets package
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/libwebsockets/default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/pkgs/development/libraries/libwebsockets/default.nix b/pkgs/development/libraries/libwebsockets/default.nix
new file mode 100644
index 000000000000..7153748348ae
--- /dev/null
+++ b/pkgs/development/libraries/libwebsockets/default.nix
@@ -0,0 +1,27 @@
+{ fetchgit, stdenv, cmake, openssl, zlib }:
+
+stdenv.mkDerivation rec {
+  name = "libwebsockets-1.4";
+
+  src = fetchgit {
+    url = "git://git.libwebsockets.org/libwebsockets";
+    rev = "16fb0132cec0fcced29bce6d86eaf94a9beb9785";
+    sha256 = "fa4c81f86dfc39211b78c53c804efc19e15b81ccb05e72699220bbed27204c7d";
+  };
+
+  buildInputs = [ cmake openssl zlib ];
+
+  meta = {
+    description = "Light, portable C library for websockets";
+    longDescription = ''
+      Libwebsockets is a lightweight pure C library built to
+      use minimal CPU and memory resources, and provide fast
+      throughput in both directions.
+    '';
+    homepage = https://libwebsockets.org/trac/libwebsockets;
+    # See http://git.libwebsockets.org/cgi-bin/cgit/libwebsockets/tree/LICENSE
+    license = stdenv.lib.licenses.gpl2Plus;
+    maintainers = [ ];
+    platforms = stdenv.lib.platforms.all;
+  };
+}