summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorvolth <volth@webmaster.ms>2018-06-27 14:27:58 +0000
committerxeji <36407913+xeji@users.noreply.github.com>2018-06-27 16:27:58 +0200
commitb43c7bd934f783709e761e5cef662ac6945758da (patch)
tree4667a4a2104751cb54614c07e3ab76f892522eb8 /pkgs/development
parentdda16ec6ad2705e5a074be70d774b5f6e0e1f555 (diff)
downloadnixlib-b43c7bd934f783709e761e5cef662ac6945758da.tar
nixlib-b43c7bd934f783709e761e5cef662ac6945758da.tar.gz
nixlib-b43c7bd934f783709e761e5cef662ac6945758da.tar.bz2
nixlib-b43c7bd934f783709e761e5cef662ac6945758da.tar.lz
nixlib-b43c7bd934f783709e761e5cef662ac6945758da.tar.xz
nixlib-b43c7bd934f783709e761e5cef662ac6945758da.tar.zst
nixlib-b43c7bd934f783709e761e5cef662ac6945758da.zip
automake111x: fix for perl5.26 ("Unescaped left brace in regex is illegal here") (#42649)
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/tools/misc/automake/automake-1.11.x.nix2
-rw-r--r--pkgs/development/tools/misc/automake/fix-perl-5.26.patch10
2 files changed, 11 insertions, 1 deletions
diff --git a/pkgs/development/tools/misc/automake/automake-1.11.x.nix b/pkgs/development/tools/misc/automake/automake-1.11.x.nix
index 9b4864e92fe5..0a3316005236 100644
--- a/pkgs/development/tools/misc/automake/automake-1.11.x.nix
+++ b/pkgs/development/tools/misc/automake/automake-1.11.x.nix
@@ -15,7 +15,7 @@ stdenv.mkDerivation rec {
     sha256 = "1ffbc6cc41f0ea6c864fbe9485b981679dc5e350f6c4bc6c3512f5a4226936b5";
   };
 
-  patches = [ ./fix-test-autoconf-2.69.patch ];
+  patches = [ ./fix-test-autoconf-2.69.patch ./fix-perl-5.26.patch ];
 
   buildInputs = [perl autoconf makeWrapper];
 
diff --git a/pkgs/development/tools/misc/automake/fix-perl-5.26.patch b/pkgs/development/tools/misc/automake/fix-perl-5.26.patch
new file mode 100644
index 000000000000..fb2d08de6d81
--- /dev/null
+++ b/pkgs/development/tools/misc/automake/fix-perl-5.26.patch
@@ -0,0 +1,10 @@
+--- automake-1.11.2/automake.in
++++ automake-1.11.2/automake.in
+@@ -4156,7 +4156,7 @@ sub substitute_ac_subst_variables_worker($)
+ sub substitute_ac_subst_variables ($)
+ {
+   my ($text) = @_;
+-  $text =~ s/\${([^ \t=:+{}]+)}/&substitute_ac_subst_variables_worker ($1)/ge;
++  $text =~ s/\$\{([^ \t=:+{}]+)}/&substitute_ac_subst_variables_worker ($1)/ge;
+   return $text;
+ }