summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorDaiderd Jordan <daiderd@gmail.com>2018-01-27 18:25:51 +0100
committerGitHub <noreply@github.com>2018-01-27 18:25:51 +0100
commitb119c18e92dcfbfb437b6af4401cb1cb021e1ecd (patch)
tree78312b7fe42d03edd5316524bdd31136e560bc54 /pkgs/development
parent38fbc93f46415d645d8325526e61eecb9ea76343 (diff)
parent7857399288e9c9e04569f777912789118b215a2a (diff)
downloadnixlib-b119c18e92dcfbfb437b6af4401cb1cb021e1ecd.tar
nixlib-b119c18e92dcfbfb437b6af4401cb1cb021e1ecd.tar.gz
nixlib-b119c18e92dcfbfb437b6af4401cb1cb021e1ecd.tar.bz2
nixlib-b119c18e92dcfbfb437b6af4401cb1cb021e1ecd.tar.lz
nixlib-b119c18e92dcfbfb437b6af4401cb1cb021e1ecd.tar.xz
nixlib-b119c18e92dcfbfb437b6af4401cb1cb021e1ecd.tar.zst
nixlib-b119c18e92dcfbfb437b6af4401cb1cb021e1ecd.zip
Merge pull request #34227 from thefloweringash/rust-darwin-dont-strip
rustc: Fix corrupted .rlib files caused by stripping on Darwin
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/compilers/rust/rustc.nix6
1 files changed, 6 insertions, 0 deletions
diff --git a/pkgs/development/compilers/rust/rustc.nix b/pkgs/development/compilers/rust/rustc.nix
index b7808ab6ec0f..482f875054f8 100644
--- a/pkgs/development/compilers/rust/rustc.nix
+++ b/pkgs/development/compilers/rust/rustc.nix
@@ -37,6 +37,12 @@ stdenv.mkDerivation {
   # The build will fail at the very end on AArch64 without this.
   dontUpdateAutotoolsGnuConfigScripts = if stdenv.isAarch64 then true else null;
 
+  # Running the default `strip -S` command on Darwin corrupts the
+  # .rlib files in "lib/".
+  #
+  # See https://github.com/NixOS/nixpkgs/pull/34227
+  stripDebugList = if stdenv.isDarwin then [ "bin" ] else null;
+
   NIX_LDFLAGS = optionalString stdenv.isDarwin "-rpath ${llvmShared}/lib";
 
   # Enable nightly features in stable compiles (used for