summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorMatthew Maurer <matthew.r.maurer@gmail.com>2016-09-13 19:22:25 -0400
committerMatthew Maurer <matthew.r.maurer@gmail.com>2016-09-14 02:35:18 -0400
commitb0c76ca173e9a1d8daf7778df3097afc0164aebb (patch)
treebe0266531e1e1177ef71cda738829ca3a7dcdebf /pkgs/development
parentd97392c39ad9f6dbd37325e55fa53d3f647a8a78 (diff)
downloadnixlib-b0c76ca173e9a1d8daf7778df3097afc0164aebb.tar
nixlib-b0c76ca173e9a1d8daf7778df3097afc0164aebb.tar.gz
nixlib-b0c76ca173e9a1d8daf7778df3097afc0164aebb.tar.bz2
nixlib-b0c76ca173e9a1d8daf7778df3097afc0164aebb.tar.lz
nixlib-b0c76ca173e9a1d8daf7778df3097afc0164aebb.tar.xz
nixlib-b0c76ca173e9a1d8daf7778df3097afc0164aebb.tar.zst
nixlib-b0c76ca173e9a1d8daf7778df3097afc0164aebb.zip
ppx_jane: init at 113.33.03
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/ocaml-modules/janestreet/ppx-jane.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/pkgs/development/ocaml-modules/janestreet/ppx-jane.nix b/pkgs/development/ocaml-modules/janestreet/ppx-jane.nix
new file mode 100644
index 000000000000..d138ef0b24e2
--- /dev/null
+++ b/pkgs/development/ocaml-modules/janestreet/ppx-jane.nix
@@ -0,0 +1,22 @@
+{stdenv, buildOcamlJane,
+ ppx_assert,
+ ppx_bench, ppx_bin_prot, ppx_compare, ppx_custom_printf, ppx_driver,
+ ppx_enumerate, ppx_expect, ppx_fail, ppx_fields_conv, ppx_here,
+ ppx_inline_test, ppx_let, ppx_pipebang, ppx_sexp_conv, ppx_sexp_message,
+ ppx_sexp_value, ppx_typerep_conv, ppx_variants_conv}:
+
+buildOcamlJane rec {
+  name = "ppx_jane";
+  hash  = "1la0rp8fhzfglwb15gqh1pl1ld8ls4cnidaw9mjc5q1hb0yj1qd9";
+  propagatedBuildInputs =
+    [ ppx_assert ppx_bench ppx_bin_prot ppx_compare ppx_custom_printf
+      ppx_driver ppx_enumerate ppx_expect ppx_fail ppx_fields_conv
+      ppx_here ppx_inline_test ppx_let ppx_pipebang ppx_sexp_conv
+      ppx_sexp_message ppx_sexp_value ppx_typerep_conv ppx_variants_conv ];
+
+  meta = with stdenv.lib; {
+    description = "ppx_jane is a ppx_driver including all standard ppx rewriters.";
+    maintainers = [ maintainers.maurer ];
+    license = licenses.asl20;
+  };
+}