summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorFrederik Rietdijk <freddyrietdijk@fridh.nl>2017-09-14 13:19:04 +0200
committerGitHub <noreply@github.com>2017-09-14 13:19:04 +0200
commitaff5ef6481000eee9b61360d6eb92a339ffd67fc (patch)
tree6a730b4dd15598687bd0cdcd48b354cb6272eadf /pkgs/development
parent4b78d44ab6a4c9d8f7b5c719985851f4a636b6ea (diff)
parent3f5f208d1390c79bbcb74f52a0e422c1d5ecf2c0 (diff)
downloadnixlib-aff5ef6481000eee9b61360d6eb92a339ffd67fc.tar
nixlib-aff5ef6481000eee9b61360d6eb92a339ffd67fc.tar.gz
nixlib-aff5ef6481000eee9b61360d6eb92a339ffd67fc.tar.bz2
nixlib-aff5ef6481000eee9b61360d6eb92a339ffd67fc.tar.lz
nixlib-aff5ef6481000eee9b61360d6eb92a339ffd67fc.tar.xz
nixlib-aff5ef6481000eee9b61360d6eb92a339ffd67fc.tar.zst
nixlib-aff5ef6481000eee9b61360d6eb92a339ffd67fc.zip
Merge pull request #29360 from disassembler/ws4py
ws4py: add git to checkInputs
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/ws4py/default.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/ws4py/default.nix b/pkgs/development/python-modules/ws4py/default.nix
new file mode 100644
index 000000000000..dff729a9c117
--- /dev/null
+++ b/pkgs/development/python-modules/ws4py/default.nix
@@ -0,0 +1,26 @@
+{ stdenv, buildPythonPackage, fetchPypi, pytest, mock, git, asyncio
+, cherrypy, gevent, tornado }:
+
+buildPythonPackage rec {
+  name = "${pname}-${version}";
+  pname = "ws4py";
+  version = "0.4.2";
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "0zr3254ky6r7q15l3dhdczfa8i723055zdkqssjifsgcwvirriks";
+  };
+
+  checkInputs = [ pytest mock git ];
+  propagatedBuildInputs = [ asyncio cherrypy gevent tornado ];
+
+  checkPhase = ''
+    pytest test
+  '';
+
+  meta = with stdenv.lib; {
+    homepage = https://ws4py.readthedocs.org;
+    description = "A WebSocket package for Python";
+    maintainers = with maintainers; [ rickynils ];
+  };
+}