summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorOwen Lynch <oclynch888@gmail.com>2017-12-26 22:32:23 -0500
committerOwen Lynch <oclynch888@gmail.com>2017-12-26 22:32:23 -0500
commitafd198f0f49c3b0172bb12133321f3fa38595199 (patch)
tree6a69bf5542687966b014bcb42610b0e23123c907 /pkgs/development
parent4d5837fc0897f2e8065ad7cf78846ff8a7b8d1dd (diff)
downloadnixlib-afd198f0f49c3b0172bb12133321f3fa38595199.tar
nixlib-afd198f0f49c3b0172bb12133321f3fa38595199.tar.gz
nixlib-afd198f0f49c3b0172bb12133321f3fa38595199.tar.bz2
nixlib-afd198f0f49c3b0172bb12133321f3fa38595199.tar.lz
nixlib-afd198f0f49c3b0172bb12133321f3fa38595199.tar.xz
nixlib-afd198f0f49c3b0172bb12133321f3fa38595199.tar.zst
nixlib-afd198f0f49c3b0172bb12133321f3fa38595199.zip
mitschemeX11: init at 9.2
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/compilers/mit-scheme/default.nix7
1 files changed, 5 insertions, 2 deletions
diff --git a/pkgs/development/compilers/mit-scheme/default.nix b/pkgs/development/compilers/mit-scheme/default.nix
index 076f3c956750..4670f39eac18 100644
--- a/pkgs/development/compilers/mit-scheme/default.nix
+++ b/pkgs/development/compilers/mit-scheme/default.nix
@@ -1,4 +1,5 @@
-{ fetchurl, stdenv, makeWrapper, gnum4, texinfo, texLive, automake }:
+{ fetchurl, stdenv, makeWrapper, gnum4, texinfo, texLive, automake,
+  enableX11 ? false, xlibsWrapper ? null }:
 
 let
   version = "9.2";
@@ -9,7 +10,7 @@ let
          else                         "";
 in
 stdenv.mkDerivation {
-  name = "mit-scheme-${version}";
+  name = if enableX11 then "mit-scheme-x11-${version}" else "mit-scheme-${version}";
 
   # MIT/GNU Scheme is not bootstrappable, so it's recommended to compile from
   # the platform-specific tarballs, which contain pre-built binaries.  It
@@ -29,6 +30,8 @@ stdenv.mkDerivation {
       sha256 = "0w5ib5vsidihb4hb6fma3sp596ykr8izagm57axvgd6lqzwicsjg";
     };
 
+  buildInputs = if enableX11 then [xlibsWrapper] else [];
+
   configurePhase =
     '' (cd src && ./configure)
        (cd doc && ./configure)