summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorsternenseemann <git@lukasepple.de>2016-11-03 11:36:40 +0100
committersternenseemann <git@lukasepple.de>2016-11-18 14:42:12 +0100
commitae13a18c6a464ed700af116ee7efc4aa988d51a6 (patch)
treef059225c88d22e884bdc291c4b2da16688fe15af /pkgs/development
parentd1b4358453cf76900cc5b51c0221abdee0eb356e (diff)
downloadnixlib-ae13a18c6a464ed700af116ee7efc4aa988d51a6.tar
nixlib-ae13a18c6a464ed700af116ee7efc4aa988d51a6.tar.gz
nixlib-ae13a18c6a464ed700af116ee7efc4aa988d51a6.tar.bz2
nixlib-ae13a18c6a464ed700af116ee7efc4aa988d51a6.tar.lz
nixlib-ae13a18c6a464ed700af116ee7efc4aa988d51a6.tar.xz
nixlib-ae13a18c6a464ed700af116ee7efc4aa988d51a6.tar.zst
nixlib-ae13a18c6a464ed700af116ee7efc4aa988d51a6.zip
ocaml-erm_xmpp_0_3: init at 0.3
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/ocaml-modules/erm_xmpp/0.3.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/pkgs/development/ocaml-modules/erm_xmpp/0.3.nix b/pkgs/development/ocaml-modules/erm_xmpp/0.3.nix
new file mode 100644
index 000000000000..a7290c8bb98f
--- /dev/null
+++ b/pkgs/development/ocaml-modules/erm_xmpp/0.3.nix
@@ -0,0 +1,29 @@
+{ stdenv, buildOcaml, fetchFromGitHub, fetchurl, ocaml, findlib, erm_xml, nocrypto }:
+
+buildOcaml rec {
+  version = "0.3";
+  name = "erm_xmpp";
+
+  src = fetchFromGitHub {
+    owner  = "hannesm";
+    repo   = "xmpp";
+    rev    = "eee18bd3dd343550169969c0b45548eafd51cfe1";
+    sha256 = "0hzs528lrx1ayalv6fh555pjn0b4l8xch1f72hd3b07g1xahdas5";
+  };
+
+  buildInputs = [ ocaml findlib ];
+  propagatedBuildInputs = [ erm_xml nocrypto ];
+
+  configurePhase = "ocaml setup.ml -configure --prefix $out";
+  buildPhase = "ocaml setup.ml -build";
+  installPhase = "ocaml setup.ml -install";
+
+  createFindlibDestdir = true;
+
+  meta = {
+    homepage = https://github.com/hannesm/xmpp;
+    description = "OCaml based XMPP implementation (fork)";
+    license = stdenv.lib.licenses.bsd3;
+    maintainers = with stdenv.lib.maintainers; [ sternenseemann ];
+  };
+}