summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorLuca Bruno <lethalman88@gmail.com>2015-09-03 10:16:29 +0200
committerLuca Bruno <lethalman88@gmail.com>2015-09-03 11:10:06 +0200
commitad99ea691246dbe6c0bd0aeb8b7914869a720917 (patch)
tree3a92e9ad3d2036f5d55e1bfe4216f2283a27f171 /pkgs/development
parentc7580cd17568ddd855774a8391fad14fd6d97be8 (diff)
downloadnixlib-ad99ea691246dbe6c0bd0aeb8b7914869a720917.tar
nixlib-ad99ea691246dbe6c0bd0aeb8b7914869a720917.tar.gz
nixlib-ad99ea691246dbe6c0bd0aeb8b7914869a720917.tar.bz2
nixlib-ad99ea691246dbe6c0bd0aeb8b7914869a720917.tar.lz
nixlib-ad99ea691246dbe6c0bd0aeb8b7914869a720917.tar.xz
nixlib-ad99ea691246dbe6c0bd0aeb8b7914869a720917.tar.zst
nixlib-ad99ea691246dbe6c0bd0aeb8b7914869a720917.zip
wml: fix build and unbreak
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/web/wml/default.nix22
1 files changed, 16 insertions, 6 deletions
diff --git a/pkgs/development/web/wml/default.nix b/pkgs/development/web/wml/default.nix
index 6dc7b68c71c2..22cc5001c920 100644
--- a/pkgs/development/web/wml/default.nix
+++ b/pkgs/development/web/wml/default.nix
@@ -20,30 +20,40 @@ perlPackages.buildPerlPackage rec {
     sed -i '/p2_mp4h\/doc/d' Makefile.in
   '';
   
-  buildInputs = [ perlPackages.perl ncurses lynx makeWrapper ];
+  buildInputs = with perlPackages; 
+    [ perl TermReadKey GD BitVector ncurses lynx makeWrapper ImageSize ];
 
   patches = [ ./redhat-with-thr.patch ./dynaloader.patch ./no_bitvector.patch ];
   
-  preFixup = ''
-    substituteInPlace $out/bin/wml \
+  postPatch = ''
+    substituteInPlace wml_frontend/wml.src \
       --replace "File::PathConvert::realpath" "Cwd::realpath" \
       --replace "File::PathConvert::abs2rel" "File::Spec->abs2rel" \
       --replace "File::PathConvert" "File::Spec"
 
+    for i in wml_include/des/imgbg.src wml_include/des/imgdot.src; do
+      substituteInPlace $i \
+        --replace "WML::GD" "GD"
+    done
+
+    rm wml_test/t/11-wmk.t
+  '';
+
+  preFixup = ''
     wrapProgram $out/bin/wml \
       --set PERL5LIB ${with perlPackages; stdenv.lib.makePerlPath [
         BitVector TermReadKey ImageSize
       ]}
   '';
 
-  enableParallelBuilding = true;
+  enableParallelBuilding = false;
+
+  installTargets = "install";
 
   meta = with stdenv.lib; {
     homepage = http://thewml.org/;
     description = "Off-line HTML generation toolkit for Unix";
     license = licenses.gpl2;
     platforms = platforms.linux;
-    # Not sure what broke this build, it used to work
-    broken = true;
   };
 }