summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorMalcolm Matalka <mmatalka@gmail.com>2013-10-12 12:03:14 +0200
committerEvgeny Egorochkin <phreedom@yandex.ru>2013-10-19 18:07:20 +0300
commitab744d2053a64ca13506e1533a3e69c00162c32b (patch)
treea87a12b39a0eec2c6680818314ce6493554ca0aa /pkgs/development
parent1dd072f70d824b803d4e18d787ae26eef8bb598f (diff)
downloadnixlib-ab744d2053a64ca13506e1533a3e69c00162c32b.tar
nixlib-ab744d2053a64ca13506e1533a3e69c00162c32b.tar.gz
nixlib-ab744d2053a64ca13506e1533a3e69c00162c32b.tar.bz2
nixlib-ab744d2053a64ca13506e1533a3e69c00162c32b.tar.lz
nixlib-ab744d2053a64ca13506e1533a3e69c00162c32b.tar.xz
nixlib-ab744d2053a64ca13506e1533a3e69c00162c32b.tar.zst
nixlib-ab744d2053a64ca13506e1533a3e69c00162c32b.zip
Add Ocaml 4.01.0.
Close #1065.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/compilers/ocaml/4.01.0.nix63
1 files changed, 63 insertions, 0 deletions
diff --git a/pkgs/development/compilers/ocaml/4.01.0.nix b/pkgs/development/compilers/ocaml/4.01.0.nix
new file mode 100644
index 000000000000..c11bb7536be1
--- /dev/null
+++ b/pkgs/development/compilers/ocaml/4.01.0.nix
@@ -0,0 +1,63 @@
+{ stdenv, fetchurl, ncurses, x11 }:
+
+let
+   useX11 = !stdenv.isArm && !stdenv.isMips;
+   useNativeCompilers = !stdenv.isMips;
+   inherit (stdenv.lib) optionals optionalString;
+in
+
+stdenv.mkDerivation rec {
+
+  name = "ocaml-4.01.0";
+
+  src = fetchurl {
+    url = "http://caml.inria.fr/pub/distrib/ocaml-4.01/${name}.tar.bz2";
+    sha256 = "b1ca708994180236917ae79e17606da5bd334ca6acd6873a550027e1c0ec874a";
+  };
+
+  prefixKey = "-prefix ";
+  configureFlags = ["-no-tk"] ++ optionals useX11 [ "-x11lib" x11 ];
+  buildFlags = "world" + optionalString useNativeCompilers " bootstrap world.opt";
+  buildInputs = [ncurses] ++ optionals useX11 [ x11 ];
+  installTargets = "install" + optionalString useNativeCompilers " installopt";
+  preConfigure = ''
+    CAT=$(type -tp cat)
+    sed -e "s@/bin/cat@$CAT@" -i config/auto-aux/sharpbang
+  '';
+  postBuild = ''
+    mkdir -p $out/include
+    ln -sv $out/lib/ocaml/caml $out/include/caml
+  '';
+
+  passthru = {
+    nativeCompilers = useNativeCompilers;
+  };
+
+  meta = {
+    homepage = http://caml.inria.fr/ocaml;
+    licenses = [ "QPL" /* compiler */ "LGPLv2" /* library */ ];
+    description = "OCaml, the most popular variant of the Caml language";
+
+    longDescription =
+      ''
+        OCaml is the most popular variant of the Caml language.  From a
+        language standpoint, it extends the core Caml language with a
+        fully-fledged object-oriented layer, as well as a powerful module
+        system, all connected by a sound, polymorphic type system featuring
+        type inference.
+
+        The OCaml system is an industrial-strength implementation of this
+        language, featuring a high-performance native-code compiler (ocamlopt)
+        for 9 processor architectures (IA32, PowerPC, AMD64, Alpha, Sparc,
+        Mips, IA64, HPPA, StrongArm), as well as a bytecode compiler (ocamlc)
+        and an interactive read-eval-print loop (ocaml) for quick development
+        and portability.  The OCaml distribution includes a comprehensive
+        standard library, a replay debugger (ocamldebug), lexer (ocamllex) and
+        parser (ocamlyacc) generators, a pre-processor pretty-printer (camlp4)
+        and a documentation generator (ocamldoc).
+      '';
+
+    platforms = stdenv.lib.platforms.linux ++ stdenv.lib.platforms.darwin;
+  };
+
+}