summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorVincent Laporte <Vincent.Laporte@gmail.com>2018-09-21 17:02:48 +0000
committerVincent Laporte <Vincent.Laporte@gmail.com>2018-09-21 17:04:22 +0000
commitab2f86aec3c5d9bc97041a47b76bfe757a33e19a (patch)
treec2a8dbf08b20aefd972f8505d6a611a19f81e69f /pkgs/development
parentda84efcd12dd3029e42b3bd0a384fe8634913cda (diff)
downloadnixlib-ab2f86aec3c5d9bc97041a47b76bfe757a33e19a.tar
nixlib-ab2f86aec3c5d9bc97041a47b76bfe757a33e19a.tar.gz
nixlib-ab2f86aec3c5d9bc97041a47b76bfe757a33e19a.tar.bz2
nixlib-ab2f86aec3c5d9bc97041a47b76bfe757a33e19a.tar.lz
nixlib-ab2f86aec3c5d9bc97041a47b76bfe757a33e19a.tar.xz
nixlib-ab2f86aec3c5d9bc97041a47b76bfe757a33e19a.tar.zst
nixlib-ab2f86aec3c5d9bc97041a47b76bfe757a33e19a.zip
ocamlPackages.erm_xml: 0.3 -> 0.3+20180112
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/ocaml-modules/erm_xml/default.nix12
1 files changed, 6 insertions, 6 deletions
diff --git a/pkgs/development/ocaml-modules/erm_xml/default.nix b/pkgs/development/ocaml-modules/erm_xml/default.nix
index c944752ff6b6..35b5c73b578b 100644
--- a/pkgs/development/ocaml-modules/erm_xml/default.nix
+++ b/pkgs/development/ocaml-modules/erm_xml/default.nix
@@ -1,17 +1,17 @@
 { stdenv, fetchzip, ocaml, findlib, ocamlbuild }:
 
-if stdenv.lib.versionAtLeast ocaml.version "4.06"
+if !stdenv.lib.versionAtLeast ocaml.version "4.02"
 then throw "erm_xml is not available for OCaml ${ocaml.version}"
 else
 
-let version = "0.3"; in
+let version = "0.3+20180112"; in
 
 stdenv.mkDerivation {
-  name = "ocaml-erm_xml-${version}";
+  name = "ocaml${ocaml.version}-erm_xml-${version}";
 
   src = fetchzip {
-    url = "https://github.com/ermine/xml/archive/v${version}.tar.gz";
-    sha256 = "19znk5w0qiw3wij4n6w3h5bcr221yy57jf815fr8k9m8kin710g3";
+    url = "https://github.com/hannesm/xml/archive/bbabdade807d8281fc48806da054b70dfe482479.tar.gz";
+    sha256 = "1gawpmg8plip0wia0xq60m024dn7l3ykwbjpbqx9f9bdmx74n1rr";
   };
 
   buildInputs = [ ocaml findlib ocamlbuild ];
@@ -19,7 +19,7 @@ stdenv.mkDerivation {
   createFindlibDestdir = true;
 
   meta = {
-    homepage = https://github.com/ermine/xml;
+    homepage = https://github.com/hannesm/xml;
     description = "XML Parser for discrete data";
     platforms = ocaml.meta.platforms or [];
     license = stdenv.lib.licenses.bsd3;