summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2013-02-19 10:09:39 -0500
committerShea Levy <shea@shealevy.com>2013-02-19 10:09:39 -0500
commitaacca1902cbb7117d978199323cf7bc1ffa4ee97 (patch)
tree00d3f88fac66fd7cdd37d4e288145f24bbeb30f8 /pkgs/development
parentb6c71e6eb3ddd36073516de29c571efab6914613 (diff)
parent7dfd7a93d43eb391e1177b881cc40ed47706ddca (diff)
downloadnixlib-aacca1902cbb7117d978199323cf7bc1ffa4ee97.tar
nixlib-aacca1902cbb7117d978199323cf7bc1ffa4ee97.tar.gz
nixlib-aacca1902cbb7117d978199323cf7bc1ffa4ee97.tar.bz2
nixlib-aacca1902cbb7117d978199323cf7bc1ffa4ee97.tar.lz
nixlib-aacca1902cbb7117d978199323cf7bc1ffa4ee97.tar.xz
nixlib-aacca1902cbb7117d978199323cf7bc1ffa4ee97.tar.zst
nixlib-aacca1902cbb7117d978199323cf7bc1ffa4ee97.zip
Merge branch 'upstream-master' into stdenv-updates
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/snappy/default.nix23
-rw-r--r--pkgs/development/tools/haskell/BNFC/default.nix4
-rw-r--r--pkgs/development/tools/misc/texinfo/4.13a.nix (renamed from pkgs/development/tools/misc/texinfo/default.nix)0
-rw-r--r--pkgs/development/tools/misc/texinfo/5.0.nix36
4 files changed, 62 insertions, 1 deletions
diff --git a/pkgs/development/libraries/snappy/default.nix b/pkgs/development/libraries/snappy/default.nix
new file mode 100644
index 000000000000..ff1bfa7d4eb3
--- /dev/null
+++ b/pkgs/development/libraries/snappy/default.nix
@@ -0,0 +1,23 @@
+{ stdenv, fetchurl }:
+
+stdenv.mkDerivation rec {
+  name = "snappy-1.1.0";
+  
+  src = fetchurl {
+    url = "http://snappy.googlecode.com/files/${name}.tar.gz";
+    sha256 = "0q31cx3zkw0apx1fy8z3xlh2lvivssvykqn0vxsgm4xvi32jpa0z";
+  };
+
+  # -DNDEBUG for speed
+  preConfigure = ''
+    configureFlagsArray=("CXXFLAGS=-DNDEBUG -O2")
+  '';
+
+  doCheck = true;
+
+  meta = {
+    homepage = http://code.google.com/p/snappy/;
+    license = "BSD";
+    description = "Compression/decompression library for very high speeds";
+  };
+}
diff --git a/pkgs/development/tools/haskell/BNFC/default.nix b/pkgs/development/tools/haskell/BNFC/default.nix
index c6cbc4a53587..3cb85b86acbd 100644
--- a/pkgs/development/tools/haskell/BNFC/default.nix
+++ b/pkgs/development/tools/haskell/BNFC/default.nix
@@ -1,4 +1,4 @@
-{ cabal, mtl }:
+{ cabal, mtl, fetchurl }:
 
 cabal.mkDerivation (self: {
   pname = "BNFC";
@@ -7,6 +7,8 @@ cabal.mkDerivation (self: {
   isLibrary = true;
   isExecutable = true;
   buildDepends = [ mtl ];
+  patches = [ (fetchurl { url = "https://github.com/BNFC/bnfc/pull/3.patch"; sha256 = "103l04ylzswgxrmpv5zy6dd0jyr96z21mdkpgk1z4prvn8wjl624"; }) ];
+  patchFlags = "-p2";
   meta = {
     homepage = "http://bnfc.digitalgrammars.com/";
     description = "A compiler front-end generator";
diff --git a/pkgs/development/tools/misc/texinfo/default.nix b/pkgs/development/tools/misc/texinfo/4.13a.nix
index 9a41d2963424..9a41d2963424 100644
--- a/pkgs/development/tools/misc/texinfo/default.nix
+++ b/pkgs/development/tools/misc/texinfo/4.13a.nix
diff --git a/pkgs/development/tools/misc/texinfo/5.0.nix b/pkgs/development/tools/misc/texinfo/5.0.nix
new file mode 100644
index 000000000000..a4fb2e9b4688
--- /dev/null
+++ b/pkgs/development/tools/misc/texinfo/5.0.nix
@@ -0,0 +1,36 @@
+{ stdenv, fetchurl, ncurses, perl }:
+
+stdenv.mkDerivation rec {
+  name = "texinfo-5.0";
+
+  src = fetchurl {
+    url = "mirror://gnu/texinfo/${name}.tar.xz";
+    sha256 = "1p34f68h9ggfj6ckgj0p62qlj7pmz3ha3vc91kh4hr44pnwm1pla";
+  };
+
+  buildInputs = [ ncurses perl ];
+
+  doCheck = true;
+
+  meta = {
+    homepage = "http://www.gnu.org/software/texinfo/";
+    description = "GNU Texinfo, the GNU documentation system";
+    license = stdenv.lib.licenses.gpl3Plus;
+
+    longDescription = ''
+      Texinfo is the official documentation format of the GNU project.
+      It was invented by Richard Stallman and Bob Chassell many years
+      ago, loosely based on Brian Reid's Scribe and other formatting
+      languages of the time.  It is used by many non-GNU projects as
+      well.
+
+      Texinfo uses a single source file to produce output in a number
+      of formats, both online and printed (dvi, html, info, pdf, xml,
+      etc.).  This means that instead of writing different documents
+      for online information and another for a printed manual, you
+      need write only one document.  And when the work is revised, you
+      need revise only that one document.  The Texinfo system is
+      well-integrated with GNU Emacs.
+    '';
+  };
+}