summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorShea Levy <shea@shealevy.com>2012-08-26 16:02:04 -0400
committerShea Levy <shea@shealevy.com>2012-08-26 16:02:04 -0400
commita94e8d275626d34435d10832a6184625144862fe (patch)
treef31c64e026f49b583e167cb3835682dd2f827a3b /pkgs/development
parent9a8b0b644b8b53c7790dd67991e52808dc3cd8ac (diff)
downloadnixlib-a94e8d275626d34435d10832a6184625144862fe.tar
nixlib-a94e8d275626d34435d10832a6184625144862fe.tar.gz
nixlib-a94e8d275626d34435d10832a6184625144862fe.tar.bz2
nixlib-a94e8d275626d34435d10832a6184625144862fe.tar.lz
nixlib-a94e8d275626d34435d10832a6184625144862fe.tar.xz
nixlib-a94e8d275626d34435d10832a6184625144862fe.tar.zst
nixlib-a94e8d275626d34435d10832a6184625144862fe.zip
Add npm2nix as a nodePackage
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/tools/node/npm2nix/default.nix26
1 files changed, 0 insertions, 26 deletions
diff --git a/pkgs/development/tools/node/npm2nix/default.nix b/pkgs/development/tools/node/npm2nix/default.nix
deleted file mode 100644
index 8300a7e2bc33..000000000000
--- a/pkgs/development/tools/node/npm2nix/default.nix
+++ /dev/null
@@ -1,26 +0,0 @@
-{ stdenv, fetchurl, coffeescript }:
-
-let version = "0.1"; in
-
-stdenv.mkDerivation rec {
-  name = "npm2nix-${version}";
-
-  src = fetchurl {
-    url = "https://bitbucket.org/shlevy/npm2nix/get/${version}.tar.bz2";
-    sha256 = "14rfs114k02yc9gx0bcjqy67f9cqgkrr1dccwlzl09q9b6qs1k3k";
-  };
-
-  phases = [ "unpackPhase" "installPhase" ];
-
-  installPhase = ''
-    mkdir -p $out/bin
-    sed 's|#!/usr/bin/env coffee|#!${coffeescript}/bin/coffee|' npm2nix.coffee \
-      > $out/bin/npm2nix
-    chmod +x $out/bin/npm2nix
-  '';
-
-  meta = {
-    description = "A tool to generate nix expressions from npm packages";
-    maintainer = stdenv.lib.maintainers.shlevy;
-  };
-}