summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorMatthew Maurer <matthew.r.maurer@gmail.com>2016-09-13 17:47:01 -0400
committerMatthew Maurer <matthew.r.maurer@gmail.com>2016-09-14 02:34:33 -0400
commita65e53d768814e18f9c70146347ed22407e02ee4 (patch)
tree34329cbcdee3bcb3631362e0b4c72e8687ecd6fa /pkgs/development
parent5bdce80515554f05d6d65853ad01d144a5d9b718 (diff)
downloadnixlib-a65e53d768814e18f9c70146347ed22407e02ee4.tar
nixlib-a65e53d768814e18f9c70146347ed22407e02ee4.tar.gz
nixlib-a65e53d768814e18f9c70146347ed22407e02ee4.tar.bz2
nixlib-a65e53d768814e18f9c70146347ed22407e02ee4.tar.lz
nixlib-a65e53d768814e18f9c70146347ed22407e02ee4.tar.xz
nixlib-a65e53d768814e18f9c70146347ed22407e02ee4.tar.zst
nixlib-a65e53d768814e18f9c70146347ed22407e02ee4.zip
ppx_driver: init at 113.33.03
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/ocaml-modules/janestreet/ppx-driver.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/pkgs/development/ocaml-modules/janestreet/ppx-driver.nix b/pkgs/development/ocaml-modules/janestreet/ppx-driver.nix
new file mode 100644
index 000000000000..ca6cc7464da6
--- /dev/null
+++ b/pkgs/development/ocaml-modules/janestreet/ppx-driver.nix
@@ -0,0 +1,15 @@
+{stdenv, buildOcamlJane,
+ ppx_core, ppx_optcomp}:
+
+buildOcamlJane rec {
+  name = "ppx_driver";
+  hash = "19cpfdn1n36vl5l9d6h7c61ffn0wmiipprn5by0354i5aywj8gpn";
+  propagatedBuildInputs =
+    [ ppx_core ppx_optcomp ];
+
+  meta = with stdenv.lib; {
+    description = "A driver is an executable created from a set of OCaml AST transformers linked together with a command line frontend.";
+    maintainers = [ maintainers.maurer ];
+    license = licenses.asl20;
+  };
+}