summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorTim Steinbach <steinbach.tim@googlemail.com>2015-12-04 23:33:06 +0000
committerTim Steinbach <steinbach.tim@googlemail.com>2015-12-05 21:23:22 +0000
commita356c3fa47b31e570408dd7395bc5c0a3f464abd (patch)
treea98d7d573262950b926dc0735f1cf1dfc7443e85 /pkgs/development
parent87ba86b7daf8402679683f61a9fc4574a4d91846 (diff)
downloadnixlib-a356c3fa47b31e570408dd7395bc5c0a3f464abd.tar
nixlib-a356c3fa47b31e570408dd7395bc5c0a3f464abd.tar.gz
nixlib-a356c3fa47b31e570408dd7395bc5c0a3f464abd.tar.bz2
nixlib-a356c3fa47b31e570408dd7395bc5c0a3f464abd.tar.lz
nixlib-a356c3fa47b31e570408dd7395bc5c0a3f464abd.tar.xz
nixlib-a356c3fa47b31e570408dd7395bc5c0a3f464abd.tar.zst
nixlib-a356c3fa47b31e570408dd7395bc5c0a3f464abd.zip
kotlin: init at 1.0.0-beta-3594
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/compilers/kotlin/default.nix39
1 files changed, 39 insertions, 0 deletions
diff --git a/pkgs/development/compilers/kotlin/default.nix b/pkgs/development/compilers/kotlin/default.nix
new file mode 100644
index 000000000000..8c21fb9e2634
--- /dev/null
+++ b/pkgs/development/compilers/kotlin/default.nix
@@ -0,0 +1,39 @@
+{ stdenv, fetchurl, makeWrapper, jre, unzip, which }:
+
+stdenv.mkDerivation rec {
+  version = "1.0.0-beta-3594";
+  name = "kotlin-${version}";
+
+  src = fetchurl {
+    url = "https://github.com/JetBrains/kotlin/releases/download/build-${version}/kotlin-compiler-${version}.zip";
+    sha256 = "a633dc27bc9bc87174835ea47d5be8ec73e0a673bb46c4b9a5a784db95f3c733";
+  };
+
+  propagatedBuildInputs = [ jre which ] ;
+  buildInputs = [ makeWrapper unzip ] ;
+
+  installPhase = ''
+    mkdir -p $out
+    rm "bin/"*.bat
+    mv * $out
+
+    for p in $(ls $out/bin/) ; do
+      wrapProgram $out/bin/$p --prefix PATH ":" ${jre}/bin ;
+    done
+  '';
+
+  meta = {
+    description = "General purpose programming language";
+    longDescription = ''
+      Kotlin is a statically typed language that targets the JVM and JavaScript.
+      It is a general-purpose language intended for industry use.
+      It is developed by a team at JetBrains although it is an OSS language 
+      and has external contributors.
+    '';
+    homepage = http://kotlinlang.org/;
+    license = stdenv.lib.licenses.asl20;
+    maintainers = with stdenv.lib.maintainers;
+      [ nequissimus ];
+    platforms = stdenv.lib.platforms.all;
+  };
+}