summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorChris Ostrouchov <chris.ostrouchov@gmail.com>2018-10-16 16:54:03 -0400
committerFrederik Rietdijk <freddyrietdijk@fridh.nl>2018-10-18 11:02:23 +0200
commita340c88b2d77a4995a3dfc0c08383e2f7e3a1474 (patch)
tree945ca11ae2378955f7c4c72c61c43d7c6ee093b5 /pkgs/development
parentd063f818d5e09163dbf633aa4ae27e74315c044f (diff)
downloadnixlib-a340c88b2d77a4995a3dfc0c08383e2f7e3a1474.tar
nixlib-a340c88b2d77a4995a3dfc0c08383e2f7e3a1474.tar.gz
nixlib-a340c88b2d77a4995a3dfc0c08383e2f7e3a1474.tar.bz2
nixlib-a340c88b2d77a4995a3dfc0c08383e2f7e3a1474.tar.lz
nixlib-a340c88b2d77a4995a3dfc0c08383e2f7e3a1474.tar.xz
nixlib-a340c88b2d77a4995a3dfc0c08383e2f7e3a1474.tar.zst
nixlib-a340c88b2d77a4995a3dfc0c08383e2f7e3a1474.zip
pythonPackages.hetzner: refactor move to python-modules
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/hetzner/default.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/hetzner/default.nix b/pkgs/development/python-modules/hetzner/default.nix
new file mode 100644
index 000000000000..ccf4e1a5ba7f
--- /dev/null
+++ b/pkgs/development/python-modules/hetzner/default.nix
@@ -0,0 +1,24 @@
+{ stdenv
+, buildPythonPackage
+, fetchFromGitHub
+}:
+
+buildPythonPackage rec {
+  pname = "hetzner";
+  version = "0.8.1";
+
+  src = fetchFromGitHub {
+    repo = "hetzner";
+    owner = "aszlig";
+    rev = "v${version}";
+    sha256 = "1xd1klvjskv0pg8ginih597jkk491a55b8dq80dsm61m5sbsx3vq";
+  };
+
+  meta = with stdenv.lib; {
+    homepage = "https://github.com/RedMoonStudios/hetzner";
+    description = "High-level Python API for accessing the Hetzner robot";
+    license = licenses.bsd3;
+    maintainers = with maintainers; [ aszlig ];
+  };
+
+}