summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorFrederik Rietdijk <fridh@fridh.nl>2017-09-06 18:15:46 +0200
committerFrederik Rietdijk <fridh@fridh.nl>2017-09-07 09:28:03 +0200
commita2b8f39d636dfc3b4411aa4bc8dd42cb07d128b8 (patch)
tree75f1c060e931366419325217f2e38e8d7beb4b71 /pkgs/development
parenta4129e7b9e598389f0cbf5b3fbdb29de062b89bf (diff)
downloadnixlib-a2b8f39d636dfc3b4411aa4bc8dd42cb07d128b8.tar
nixlib-a2b8f39d636dfc3b4411aa4bc8dd42cb07d128b8.tar.gz
nixlib-a2b8f39d636dfc3b4411aa4bc8dd42cb07d128b8.tar.bz2
nixlib-a2b8f39d636dfc3b4411aa4bc8dd42cb07d128b8.tar.lz
nixlib-a2b8f39d636dfc3b4411aa4bc8dd42cb07d128b8.tar.xz
nixlib-a2b8f39d636dfc3b4411aa4bc8dd42cb07d128b8.tar.zst
nixlib-a2b8f39d636dfc3b4411aa4bc8dd42cb07d128b8.zip
python.pkgs.ftfy: disable Python 2
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/ftfy/default.nix12
1 files changed, 10 insertions, 2 deletions
diff --git a/pkgs/development/python-modules/ftfy/default.nix b/pkgs/development/python-modules/ftfy/default.nix
index e53358677029..f5d25626bcf1 100644
--- a/pkgs/development/python-modules/ftfy/default.nix
+++ b/pkgs/development/python-modules/ftfy/default.nix
@@ -5,6 +5,7 @@
 , wcwidth
 , nose
 , python
+, isPy3k
 }:
 buildPythonPackage rec {
   name = "${pname}-${version}";
@@ -18,14 +19,21 @@ buildPythonPackage rec {
 
   propagatedBuildInputs = [ html5lib wcwidth];
 
-  buildInputs = [
+  checkInputs = [
     nose
   ];
 
   checkPhase = ''
-    nosetests -v
+    nosetests -v tests
   '';
 
+  # Several tests fail with
+  # FileNotFoundError: [Errno 2] No such file or directory: 'ftfy'
+  doCheck = false;
+
+  # "this version of ftfy is no longer written for Python 2"
+  disabled = !isPy3k;
+
   meta = with stdenv.lib; {
     description = "Given Unicode text, make its representation consistent and possibly less broken.";
     homepage = https://github.com/LuminosoInsight/python-ftfy/tree/master/tests;