summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorLluís Batlle i Rossell <viric@vicerveza.homeunix.net>2010-01-07 20:39:52 +0000
committerLluís Batlle i Rossell <viric@vicerveza.homeunix.net>2010-01-07 20:39:52 +0000
commit9dcfc5263bce27d6d8abd35170740c56caee8437 (patch)
tree5725a31a253d532e8850db734ce93e4667784951 /pkgs/development
parent3a400bb64aae8c594163933f874bdcdc092842bb (diff)
downloadnixlib-9dcfc5263bce27d6d8abd35170740c56caee8437.tar
nixlib-9dcfc5263bce27d6d8abd35170740c56caee8437.tar.gz
nixlib-9dcfc5263bce27d6d8abd35170740c56caee8437.tar.bz2
nixlib-9dcfc5263bce27d6d8abd35170740c56caee8437.tar.lz
nixlib-9dcfc5263bce27d6d8abd35170740c56caee8437.tar.xz
nixlib-9dcfc5263bce27d6d8abd35170740c56caee8437.tar.zst
nixlib-9dcfc5263bce27d6d8abd35170740c56caee8437.zip
Updating poppler
svn path=/nixpkgs/trunk/; revision=19299
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/poppler/default.nix6
-rw-r--r--pkgs/development/libraries/poppler/use_exceptions.patch60
2 files changed, 3 insertions, 63 deletions
diff --git a/pkgs/development/libraries/poppler/default.nix b/pkgs/development/libraries/poppler/default.nix
index ec761b3c44f3..7c9223a91fd7 100644
--- a/pkgs/development/libraries/poppler/default.nix
+++ b/pkgs/development/libraries/poppler/default.nix
@@ -5,11 +5,11 @@
 assert qt4Support -> (qt4 != null);
 
 stdenv.mkDerivation rec {
-  name = "poppler-0.10.6";
+  name = "poppler-0.12.3";
 
   src = fetchurl {
     url = "http://poppler.freedesktop.org/${name}.tar.gz";
-    sha256 = "bcd78d674c4166af069afdb27af810c012e13cfd2b7b21f9dce63dd3f62bded1";
+    sha256 = "1k7vilpz0ipnmw9dfpb3rqkhlm4rqcnkn3bhhp14di2h55nzwkvs";
   };
 
   buildInputs = [pkgconfig zlib glib cairo freetype fontconfig libjpeg gtk]
@@ -22,7 +22,7 @@ stdenv.mkDerivation rec {
     ''
     + (if qt4Support then "--enable-qt-poppler" else "--disable-qt-poppler");
 
-  patches = [ ./GDir-const.patch ./use_exceptions.patch ];
+  patches = [ ./GDir-const.patch ];
 
   preConfigure = "sed -e '/jpeg_incdirs/s@/usr@${libjpeg}@' -i configure";
 
diff --git a/pkgs/development/libraries/poppler/use_exceptions.patch b/pkgs/development/libraries/poppler/use_exceptions.patch
deleted file mode 100644
index 4880da8e2e41..000000000000
--- a/pkgs/development/libraries/poppler/use_exceptions.patch
+++ /dev/null
@@ -1,60 +0,0 @@
-diff -ur poppler-0.6.1/goo/gmem.cc poppler-0.6.1-patched/goo/gmem.cc
---- poppler-0.6.1/goo/gmem.cc	2007-10-12 13:34:49.000000000 +0200
-+++ poppler-0.6.1-patched/goo/gmem.cc	2007-11-06 16:17:41.290632269 +0100
-@@ -60,7 +60,7 @@
-   }
-   size1 = gMemDataSize(size);
-   if (!(mem = (char *)malloc(size1 + gMemHdrSize + gMemTrlSize))) {
--#if USE_EXCEPTIONS
-+#ifdef USE_EXCEPTIONS
-     throw GMemException();
- #else
-     fprintf(stderr, "Out of memory\n");
-@@ -95,7 +95,7 @@
-     return NULL;
-   }
-   if (!(p = malloc(size))) {
--#if USE_EXCEPTIONS
-+#ifdef USE_EXCEPTIONS
-     throw GMemException();
- #else
-     fprintf(stderr, "Out of memory\n");
-@@ -143,7 +143,7 @@
-     q = malloc(size);
-   }
-   if (!q) {
--#if USE_EXCEPTIONS
-+#ifdef USE_EXCEPTIONS
-     throw GMemException();
- #else
-     fprintf(stderr, "Out of memory\n");
-@@ -162,7 +162,7 @@
-   }
-   n = nObjs * objSize;
-   if (objSize <= 0 || nObjs < 0 || nObjs >= INT_MAX / objSize) {
--#if USE_EXCEPTIONS
-+#ifdef USE_EXCEPTIONS
-     throw GMemException();
- #else
-     fprintf(stderr, "Bogus memory allocation size\n");
-@@ -183,7 +183,7 @@
-   }
-   n = nObjs * objSize;
-   if (objSize <= 0 || nObjs < 0 || nObjs >= INT_MAX / objSize) {
--#if USE_EXCEPTIONS
-+#ifdef USE_EXCEPTIONS
-     throw GMemException();
- #else
-     fprintf(stderr, "Bogus memory allocation size\n");
-diff -ur poppler-0.6.1/goo/gmem.h poppler-0.6.1-patched/goo/gmem.h
---- poppler-0.6.1/goo/gmem.h	2007-09-17 20:37:39.000000000 +0200
-+++ poppler-0.6.1-patched/goo/gmem.h	2007-11-06 16:17:46.606925527 +0100
-@@ -12,7 +12,7 @@
- #include <stdio.h>
- #include <poppler/poppler-config.h>
- 
--#if USE_EXCEPTIONS
-+#ifdef USE_EXCEPTIONS
- 
- class GMemException {
- public: