summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorrnhmjoj <rnhmjoj@inventati.org>2018-09-11 23:51:25 +0200
committerrnhmjoj <rnhmjoj@inventati.org>2018-09-12 03:23:04 +0200
commit99dad9d7f01429f03054d45da8a6468fca0f8793 (patch)
tree0ede4183673b9f06cffc99f3109b267ba954547c /pkgs/development
parenta25dcb66077310067ca1b59b2f38046bee752b0a (diff)
downloadnixlib-99dad9d7f01429f03054d45da8a6468fca0f8793.tar
nixlib-99dad9d7f01429f03054d45da8a6468fca0f8793.tar.gz
nixlib-99dad9d7f01429f03054d45da8a6468fca0f8793.tar.bz2
nixlib-99dad9d7f01429f03054d45da8a6468fca0f8793.tar.lz
nixlib-99dad9d7f01429f03054d45da8a6468fca0f8793.tar.xz
nixlib-99dad9d7f01429f03054d45da8a6468fca0f8793.tar.zst
nixlib-99dad9d7f01429f03054d45da8a6468fca0f8793.zip
python.pkgs.requests-file: init at 1.4.3
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/requests-file/default.nix20
1 files changed, 20 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/requests-file/default.nix b/pkgs/development/python-modules/requests-file/default.nix
new file mode 100644
index 000000000000..fac222176519
--- /dev/null
+++ b/pkgs/development/python-modules/requests-file/default.nix
@@ -0,0 +1,20 @@
+{ lib, fetchPypi, buildPythonPackage, requests, six }:
+
+buildPythonPackage rec {
+  pname   = "requests-file";
+  version = "1.4.3";
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "1yp2jaxg3v86pia0q512dg3hz6s9y5vzdivsgrba1kds05ial14g";
+  };
+
+  propagatedBuildInputs = [ requests six ];
+
+  meta = {
+    homepage = https://github.com/dashea/requests-file;
+    description = "Transport adapter for fetching file:// URLs with the requests python library";
+    license = lib.licenses.asl20;
+  };
+
+}