summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorNikolay Amiantov <ab@fmap.me>2015-11-04 23:07:26 +0300
committerNikolay Amiantov <ab@fmap.me>2015-11-04 23:10:36 +0300
commit997bf2c6657217481701bd2519b6aae9508ae6a9 (patch)
tree4bf9e14141acbdae866030d5800f31b5f53538d6 /pkgs/development
parente3ce30bef4d8a37054354cc280df61f80a8a341e (diff)
downloadnixlib-997bf2c6657217481701bd2519b6aae9508ae6a9.tar
nixlib-997bf2c6657217481701bd2519b6aae9508ae6a9.tar.gz
nixlib-997bf2c6657217481701bd2519b6aae9508ae6a9.tar.bz2
nixlib-997bf2c6657217481701bd2519b6aae9508ae6a9.tar.lz
nixlib-997bf2c6657217481701bd2519b6aae9508ae6a9.tar.xz
nixlib-997bf2c6657217481701bd2519b6aae9508ae6a9.tar.zst
nixlib-997bf2c6657217481701bd2519b6aae9508ae6a9.zip
vc: init at 0.7.5, 1.0.0
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/vc/0.7.nix25
-rw-r--r--pkgs/development/libraries/vc/default.nix25
2 files changed, 50 insertions, 0 deletions
diff --git a/pkgs/development/libraries/vc/0.7.nix b/pkgs/development/libraries/vc/0.7.nix
new file mode 100644
index 000000000000..932b7f50f351
--- /dev/null
+++ b/pkgs/development/libraries/vc/0.7.nix
@@ -0,0 +1,25 @@
+{ stdenv, fetchFromGitHub, cmake }:
+
+stdenv.mkDerivation rec {
+  version = "0.7.5";
+  name = "Vc-${version}";
+
+  src = fetchFromGitHub {
+    owner = "VcDevel";
+    repo = "Vc";
+    rev = version;
+    sha256 = "190s4r2n3jsivl4j2m288j3rqmgjj6gl308hi9mzwyhcfn17q8br";
+  };
+
+  nativeBuildInputs = [ cmake ];
+
+  enableParallelBuilding = true;
+
+  meta = with stdenv.lib; {
+    description = "Library for multiprecision complex arithmetic with exact rounding";
+    homepage = https://github.com/VcDevel/Vc;
+    license = licences.bsd3;
+    platforms = platforms.all;
+    maintainers = with maintainers; [ abbradar ];
+  };
+}
diff --git a/pkgs/development/libraries/vc/default.nix b/pkgs/development/libraries/vc/default.nix
new file mode 100644
index 000000000000..b019ad63cdf2
--- /dev/null
+++ b/pkgs/development/libraries/vc/default.nix
@@ -0,0 +1,25 @@
+{ stdenv, fetchFromGitHub, cmake }:
+
+stdenv.mkDerivation rec {
+  version = "1.0.0";
+  name = "Vc-${version}";
+
+  src = fetchFromGitHub {
+    owner = "VcDevel";
+    repo = "Vc";
+    rev = version;
+    sha256 = "014li9kcbbxinh9r1nngdzspjzs2nxwslcknd950msjkqgnjhz4r";
+  };
+
+  nativeBuildInputs = [ cmake ];
+
+  enableParallelBuilding = true;
+
+  meta = with stdenv.lib; {
+    description = "Library for multiprecision complex arithmetic with exact rounding";
+    homepage = https://github.com/VcDevel/Vc;
+    license = licences.bsd3;
+    platforms = platforms.all;
+    maintainers = with maintainers; [ abbradar ];
+  };
+}