summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorRobert Schütz <robert.schuetz@stud.uni-heidelberg.de>2018-02-04 22:13:11 +0100
committerRobert Schütz <robert.schuetz@stud.uni-heidelberg.de>2018-02-04 22:13:11 +0100
commit988bec8774bac1a47b7e68bf20cb21436a28574b (patch)
treec97b11ac5415b9e41a4013adcd7200404c0ab1d5 /pkgs/development
parent9ba4b1621d35029eb78fedf0306babc0ab12d215 (diff)
downloadnixlib-988bec8774bac1a47b7e68bf20cb21436a28574b.tar
nixlib-988bec8774bac1a47b7e68bf20cb21436a28574b.tar.gz
nixlib-988bec8774bac1a47b7e68bf20cb21436a28574b.tar.bz2
nixlib-988bec8774bac1a47b7e68bf20cb21436a28574b.tar.lz
nixlib-988bec8774bac1a47b7e68bf20cb21436a28574b.tar.xz
nixlib-988bec8774bac1a47b7e68bf20cb21436a28574b.tar.zst
nixlib-988bec8774bac1a47b7e68bf20cb21436a28574b.zip
python3Packages.asynctest: init at 0.11.1
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/asynctest/default.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/asynctest/default.nix b/pkgs/development/python-modules/asynctest/default.nix
new file mode 100644
index 000000000000..2b0348a87581
--- /dev/null
+++ b/pkgs/development/python-modules/asynctest/default.nix
@@ -0,0 +1,33 @@
+{ lib, buildPythonPackage, fetchPypi, fetchFromGitHub, pythonOlder, python }:
+
+buildPythonPackage rec {
+  pname = "asynctest";
+  version = "0.11.1";
+
+  disabled = pythonOlder "3.4";
+
+  # PyPI tarball doesn't ship test/__init__.py
+  src = fetchFromGitHub {
+    owner = "Martiusweb";
+    repo = pname;
+    rev = "v${version}";
+    sha256 = "1vvh5vbq2fbz6426figs85z8779r7svb4dp2v3xynhhv05nh2y6v";
+  };
+
+  postPatch = ''
+    # Skip failing test, probably caused by file system access
+    substituteInPlace test/test_selector.py \
+      --replace "test_events_watched_outside_test_are_ignored" "xtest_events_watched_outside_test_are_ignored"
+  '';
+
+  checkPhase = ''
+    ${python.interpreter} -m unittest test
+  '';
+
+  meta = with lib; {
+    description = "Enhance the standard unittest package with features for testing asyncio libraries";
+    homepage = https://github.com/Martiusweb/asynctest;
+    license = licenses.asl20;
+    maintainers = with maintainers; [ dotlambda ];
+  };
+}