summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authormakefu <github@syntax-fehler.de>2017-09-20 16:12:22 +0200
committermakefu <github@syntax-fehler.de>2017-09-25 23:23:38 +0200
commit97644a9f4f160e4a5eba77e462701f516a46b5ad (patch)
tree7512c7bc2a6502f34011baf267e7de04fa7abc20 /pkgs/development
parent72516990814a3636eac00cb0874dc29166d1e440 (diff)
downloadnixlib-97644a9f4f160e4a5eba77e462701f516a46b5ad.tar
nixlib-97644a9f4f160e4a5eba77e462701f516a46b5ad.tar.gz
nixlib-97644a9f4f160e4a5eba77e462701f516a46b5ad.tar.bz2
nixlib-97644a9f4f160e4a5eba77e462701f516a46b5ad.tar.lz
nixlib-97644a9f4f160e4a5eba77e462701f516a46b5ad.tar.xz
nixlib-97644a9f4f160e4a5eba77e462701f516a46b5ad.tar.zst
nixlib-97644a9f4f160e4a5eba77e462701f516a46b5ad.zip
keystoneauth1: enable tests
requires a later version of betamax, bumped to 0.8.0
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/keystoneauth1/default.nix17
1 files changed, 13 insertions, 4 deletions
diff --git a/pkgs/development/python-modules/keystoneauth1/default.nix b/pkgs/development/python-modules/keystoneauth1/default.nix
index 130671360488..7405f7f74cd5 100644
--- a/pkgs/development/python-modules/keystoneauth1/default.nix
+++ b/pkgs/development/python-modules/keystoneauth1/default.nix
@@ -2,6 +2,7 @@
 , pbr, testtools, testresources, testrepository, mock
 , pep8, fixtures, mox3, requests-mock
 , iso8601, requests, six, stevedore, webob, oslo-config
+, pyyaml, betamax, oauthlib
 }:
 
 buildPythonPackage rec {
@@ -15,12 +16,20 @@ buildPythonPackage rec {
     sha256 = "0rg3harfyvai34lrjiqnl1crmvswjvj8nsviasnz4b9pcvp3d03n";
   };
 
-  buildInputs = [ pbr testtools testresources testrepository mock
-                  pep8 fixtures mox3 requests-mock ];
+  buildInputs = [ pbr  ];
+  checkInputs = [ pyyaml betamax oauthlib testtools testresources
+                  testrepository mock pep8 fixtures mox3 requests-mock ];
   propagatedBuildInputs = [ iso8601 requests six stevedore webob ];
 
-  # oslo_config is required but would create a circular dependency
-  doCheck = false;
+  doCheck = true;
+  # 1. oslo-config
+  # 2. oslo-utils
+  # 3. requests-kerberos
+  preCheck = ''
+    rm keystoneauth1/tests/unit/loading/test_{session,conf,adapter}.py
+    rm keystoneauth1/tests/unit/access/test_v{2,3}_access.py
+    rm keystoneauth1/tests/unit/extras/kerberos/test_fedkerb_loading.py
+  '';
   postPatch = ''
     sed -i 's@python@${python.interpreter}@' .testr.conf
     substituteInPlace requirements.txt --replace "argparse" ""