summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorChris Ostrouchov <chris.ostrouchov@gmail.com>2018-10-16 16:32:16 -0400
committerFrederik Rietdijk <freddyrietdijk@fridh.nl>2018-10-18 11:02:23 +0200
commit968b1ab947b5016304b4ab81bea257bb2442e9c6 (patch)
treef33d9d11a66fcee2b8a4b308e39576b7f57292aa /pkgs/development
parent7771d40c054e99b8fe67ec6325774e2bdd0ce00c (diff)
downloadnixlib-968b1ab947b5016304b4ab81bea257bb2442e9c6.tar
nixlib-968b1ab947b5016304b4ab81bea257bb2442e9c6.tar.gz
nixlib-968b1ab947b5016304b4ab81bea257bb2442e9c6.tar.bz2
nixlib-968b1ab947b5016304b4ab81bea257bb2442e9c6.tar.lz
nixlib-968b1ab947b5016304b4ab81bea257bb2442e9c6.tar.xz
nixlib-968b1ab947b5016304b4ab81bea257bb2442e9c6.tar.zst
nixlib-968b1ab947b5016304b4ab81bea257bb2442e9c6.zip
pythonPackages.gipc: refactor move to python-modules
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/gipc/default.nix35
1 files changed, 35 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/gipc/default.nix b/pkgs/development/python-modules/gipc/default.nix
new file mode 100644
index 000000000000..9780b46fa5a0
--- /dev/null
+++ b/pkgs/development/python-modules/gipc/default.nix
@@ -0,0 +1,35 @@
+{ stdenv
+, buildPythonPackage
+, fetchPypi
+, isPy3k
+, gevent
+}:
+
+buildPythonPackage rec {
+  pname = "gipc";
+  version = "0.5.0";
+  disabled = isPy3k;
+
+  src = fetchPypi {
+    inherit pname version;
+    extension = "zip";
+    sha256 = "08c35xzv7nr12d9xwlywlbyzzz2igy0yy6y52q2nrkmh5d4slbpc";
+  };
+
+  propagatedBuildInputs = [ gevent ];
+
+  meta = with stdenv.lib; {
+    description = "gevent-cooperative child processes and IPC";
+    longDescription = ''
+      Usage of Python's multiprocessing package in a gevent-powered
+      application may raise problems and most likely breaks the application
+      in various subtle ways. gipc (pronunciation "gipsy") is developed with
+      the motivation to solve many of these issues transparently. With gipc,
+      multiprocessing. Process-based child processes can safely be created
+      anywhere within your gevent-powered application.
+    '';
+    homepage = http://gehrcke.de/gipc;
+    license = licenses.mit;
+  };
+
+}