summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorThomas Tuegel <ttuegel@gmail.com>2015-07-20 08:46:20 -0500
committerThomas Tuegel <ttuegel@gmail.com>2015-07-20 08:46:20 -0500
commit965f330c654553400611aa51d6898a9dd14e40dd (patch)
treec22ec20072778f691719aa15139d20e84c257b96 /pkgs/development
parent17a65c4bf043aaa35b6224a27a3d0a9df546ca85 (diff)
downloadnixlib-965f330c654553400611aa51d6898a9dd14e40dd.tar
nixlib-965f330c654553400611aa51d6898a9dd14e40dd.tar.gz
nixlib-965f330c654553400611aa51d6898a9dd14e40dd.tar.bz2
nixlib-965f330c654553400611aa51d6898a9dd14e40dd.tar.lz
nixlib-965f330c654553400611aa51d6898a9dd14e40dd.tar.xz
nixlib-965f330c654553400611aa51d6898a9dd14e40dd.tar.zst
nixlib-965f330c654553400611aa51d6898a9dd14e40dd.zip
qt5.base: disable unsupported SIMD instruction sets
If not explicitly disabled, Qt tries to detect support for the various
instruction sets. As a result, binaries built on Hydra may use
instruction sets unsupported by clients.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/qt-5/5.4/qtbase.nix12
1 files changed, 12 insertions, 0 deletions
diff --git a/pkgs/development/libraries/qt-5/5.4/qtbase.nix b/pkgs/development/libraries/qt-5/5.4/qtbase.nix
index 441dbdd5c660..ecefa891332e 100644
--- a/pkgs/development/libraries/qt-5/5.4/qtbase.nix
+++ b/pkgs/development/libraries/qt-5/5.4/qtbase.nix
@@ -25,6 +25,8 @@
 
 with stdenv.lib;
 
+let system-x86_64 = elem stdenv.system platforms.x86_64; in
+
 stdenv.mkDerivation {
 
   name = "qtbase-${version}";
@@ -125,6 +127,16 @@ stdenv.mkDerivation {
     -no-linuxfb
     -no-kms
 
+    ${optionalString (!system-x86_64) "-no-sse2"}
+    -no-sse3
+    -no-ssse3
+    -no-sse4.1
+    -no-sse4.2
+    -no-avx
+    -no-avx2
+    -no-mips_dsp
+    -no-mips_dspr2
+
     -system-zlib
     -system-libpng
     -system-libjpeg