summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorLluís Batlle i Rossell <viric@vicerveza.homeunix.net>2009-10-04 21:31:34 +0000
committerLluís Batlle i Rossell <viric@vicerveza.homeunix.net>2009-10-04 21:31:34 +0000
commit954a8d0cdc239044a9fa8bad813b777e4f3296a7 (patch)
tree7251155cd0e074bba10b1fe22431c4b189043275 /pkgs/development
parentad30d22e827045d2ccd862c1d5ef5ca076ce4184 (diff)
downloadnixlib-954a8d0cdc239044a9fa8bad813b777e4f3296a7.tar
nixlib-954a8d0cdc239044a9fa8bad813b777e4f3296a7.tar.gz
nixlib-954a8d0cdc239044a9fa8bad813b777e4f3296a7.tar.bz2
nixlib-954a8d0cdc239044a9fa8bad813b777e4f3296a7.tar.lz
nixlib-954a8d0cdc239044a9fa8bad813b777e4f3296a7.tar.xz
nixlib-954a8d0cdc239044a9fa8bad813b777e4f3296a7.tar.zst
nixlib-954a8d0cdc239044a9fa8bad813b777e4f3296a7.zip
Adding amr support in mplayer. That should be enabled by the user, because those libraries are not redistributable.
I don't know if the 'unfree' in the amr libraries will stop mplayer being built without its support. We would have to write the all-packages MPlayer expression different, in this case.

svn path=/nixpkgs/trunk/; revision=17635
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/amrnb/default.nix31
-rw-r--r--pkgs/development/libraries/amrwb/default.nix41
2 files changed, 72 insertions, 0 deletions
diff --git a/pkgs/development/libraries/amrnb/default.nix b/pkgs/development/libraries/amrnb/default.nix
new file mode 100644
index 000000000000..a2ed73934931
--- /dev/null
+++ b/pkgs/development/libraries/amrnb/default.nix
@@ -0,0 +1,31 @@
+{stdenv, fetchurl, unzip}:
+
+stdenv.mkDerivation {
+  name = "amrnb-7.0.0.2";
+  srcAmr = fetchurl {
+    url = http://www.3gpp.org/ftp/Specs/latest/Rel-7/26_series/26104-700.zip;
+    sha256 = "0hgm8dddrqiinjdjxnsw0x899czjlvplq69z4kv8y4zqnrjlwzni";
+  };
+
+  src = fetchurl {
+    url = http://ftp.penguin.cz/pub/users/utx/amr/amrnb-7.0.0.2.tar.bz2;
+    sha256 = "0z4wjr0jml973vd0dvxlmy34daiswy5axlmpvc85k8qcr08i8zaa";
+  };
+
+  buildInputs = [ unzip ];
+
+  configureFlags = [ "--cache-file=config.cache" "--with-downloader=true" ];
+
+  postConfigure = ''
+    cp $srcAmr 26104-700.zip 
+  '';
+
+  meta = {
+    homepage = http://www.penguin.cz/~utx/amr;
+    description = "AMR Narrow-Band Codec";
+    # The wrapper code is free, but not the libraries from 3gpp.
+    # It's a source code reference implementation with patents and licenses on
+    # some countries, not redistributable.
+    license = "unfree";
+  };
+}
diff --git a/pkgs/development/libraries/amrwb/default.nix b/pkgs/development/libraries/amrwb/default.nix
new file mode 100644
index 000000000000..fc8d0415c36b
--- /dev/null
+++ b/pkgs/development/libraries/amrwb/default.nix
@@ -0,0 +1,41 @@
+{stdenv, fetchurl, unzip}:
+
+stdenv.mkDerivation {
+  # The 'src' 7.0.0.3 expects amrwb 700, but there is only 710 available now,
+  # so I guess in 3gpp they updated to 7.1.0, but amrwb did not update the libraries.
+  # I guess amrwb uses the first version numbers to match those of 3gpp,
+  # so I set the name to 7.1.0.3 in this case
+  name = "amrwb-7.1.0.3";
+
+  srcAmr = fetchurl {
+    url = http://www.3gpp.org/ftp/Specs/latest/Rel-7/26_series/26204-710.zip;
+    sha256 = "1wnx72m20y8bdlyndyy8rskr0hi4llk1h1hcr34awxfmi9l4922i";
+  };
+
+  src = fetchurl {
+    url = http://ftp.penguin.cz/pub/users/utx/amr/amrwb-7.0.0.3.tar.bz2;
+    sha256 = "0nn94i3gw3d5fgks43wdhshdlhpd4rcrzj46f2vsby0viwkxxp8z";
+  };
+
+  buildInputs = [ unzip ];
+
+  patchPhase = ''
+    sed -i s/26204-700/26204-710/g Makefile.am Makefile.in configure configure.ac \
+      prepare_sources.sh.in
+  '';
+
+  configureFlags = [ "--cache-file=config.cache" "--with-downloader=true" ];
+
+  postConfigure = ''
+    cp $srcAmr 26204-710.zip 
+  '';
+
+  meta = {
+    homepage = http://www.penguin.cz/~utx/amr;
+    description = "AMR Wide-Band Codec";
+    # The wrapper code is free, but not the libraries from 3gpp.
+    # It's a source code reference implementation with patents and licenses on
+    # some countries, not redistributable.
+    license = "unfree";
+  };
+}