summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorAustin Seipp <aseipp@pobox.com>2014-05-22 14:22:31 -0500
committerAustin Seipp <aseipp@pobox.com>2014-05-22 14:22:31 -0500
commit925a016113aa54acf468ebb8ef1b3a9ebb640207 (patch)
tree15bebee1bb6182f7a944442c7cfe62717832f982 /pkgs/development
parent4241e3087444699e8e5d295b9210e592cc169f5d (diff)
parent854b1fb9fb5f482da697bb4658b97949380ce64e (diff)
downloadnixlib-925a016113aa54acf468ebb8ef1b3a9ebb640207.tar
nixlib-925a016113aa54acf468ebb8ef1b3a9ebb640207.tar.gz
nixlib-925a016113aa54acf468ebb8ef1b3a9ebb640207.tar.bz2
nixlib-925a016113aa54acf468ebb8ef1b3a9ebb640207.tar.lz
nixlib-925a016113aa54acf468ebb8ef1b3a9ebb640207.tar.xz
nixlib-925a016113aa54acf468ebb8ef1b3a9ebb640207.tar.zst
nixlib-925a016113aa54acf468ebb8ef1b3a9ebb640207.zip
Merge pull request #2521 from jwiegley/agda
Build AgdaStdlib before installing it
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/compilers/agda/stdlib.nix9
1 files changed, 7 insertions, 2 deletions
diff --git a/pkgs/development/compilers/agda/stdlib.nix b/pkgs/development/compilers/agda/stdlib.nix
index d71713674f72..c07b3e7c7dd2 100644
--- a/pkgs/development/compilers/agda/stdlib.nix
+++ b/pkgs/development/compilers/agda/stdlib.nix
@@ -1,4 +1,4 @@
-{ cabal, fetchurl }:
+{ cabal, fetchurl, filemanip, Agda }:
 
 cabal.mkDerivation (self: {
   pname = "Agda-stdlib";
@@ -9,11 +9,16 @@ cabal.mkDerivation (self: {
     sha256 = "1ynjgqk8hhnm6rbngy8fjsrd6i4phj2hlan9bk435bbywbl366k3";
   };
 
+  buildDepends = [ filemanip Agda ];
+
   preConfigure = "cd ffi";
 
   postInstall = ''
       mkdir -p $out/share
-      cp -pR ../src $out/share/agda
+      cd ..
+      runhaskell GenerateEverything
+      agda -i . -i src Everything.agda
+      cp -pR src $out/share/agda
   '';
 
   meta = {