summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorVincent Laporte <Vincent.Laporte@gmail.com>2018-05-28 05:50:12 +0000
committerVincent Laporte <Vincent.Laporte@gmail.com>2018-06-06 07:14:20 +0000
commit9114b4731454cbbe547b8a0279b5084a672e6064 (patch)
tree160dd946765a7176f93b55b711de440c6f4f5947 /pkgs/development
parent46dfe1eca806defde9a13fb8a94254ba5b086f7a (diff)
downloadnixlib-9114b4731454cbbe547b8a0279b5084a672e6064.tar
nixlib-9114b4731454cbbe547b8a0279b5084a672e6064.tar.gz
nixlib-9114b4731454cbbe547b8a0279b5084a672e6064.tar.bz2
nixlib-9114b4731454cbbe547b8a0279b5084a672e6064.tar.lz
nixlib-9114b4731454cbbe547b8a0279b5084a672e6064.tar.xz
nixlib-9114b4731454cbbe547b8a0279b5084a672e6064.tar.zst
nixlib-9114b4731454cbbe547b8a0279b5084a672e6064.zip
ocamlPackages.gg: use opaline
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/ocaml-modules/gg/default.nix9
1 files changed, 3 insertions, 6 deletions
diff --git a/pkgs/development/ocaml-modules/gg/default.nix b/pkgs/development/ocaml-modules/gg/default.nix
index 0839ff361aea..0c80f39d9d7d 100644
--- a/pkgs/development/ocaml-modules/gg/default.nix
+++ b/pkgs/development/ocaml-modules/gg/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, ocaml, findlib, ocamlbuild, opam }:
+{ stdenv, fetchurl, ocaml, findlib, ocamlbuild, opaline }:
 
 let
   inherit (stdenv.lib) getVersion versionAtLeast;
@@ -19,7 +19,7 @@ stdenv.mkDerivation rec {
     sha256 = "0czj41sr8jsivl3z8wyblf9k971j3kx2wc3s0c1nhzcc8allg9i2";
   };
 
-  buildInputs = [ ocaml findlib ocamlbuild opam ];
+  buildInputs = [ ocaml findlib ocamlbuild opaline ];
 
   createFindlibDestdir = true;
 
@@ -27,10 +27,7 @@ stdenv.mkDerivation rec {
 
   buildPhase = "ocaml pkg/build.ml native=true native-dynlink=true";
 
-  installPhase = ''
-    opam-installer --script --prefix=$out ${pname}.install | sh
-    ln -s $out/lib/${pname} $out/lib/ocaml/${getVersion ocaml}/site-lib/${pname}
-  '';
+  installPhase = "opaline -libdir $OCAMLFIND_DESTDIR";
 
   meta = with stdenv.lib; {
     description = "Basic types for computer graphics in OCaml";