summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorWill Dietz <w@wdtz.org>2018-01-13 12:20:03 -0600
committerWill Dietz <w@wdtz.org>2018-02-13 09:44:48 -0600
commit8dfe068f862a3b2e336a246655000aa73949201d (patch)
treece1780ebf18aa949894deb4ed0f1e6d91fcd1246 /pkgs/development
parentc8081971f4d35feac0342cf64dbfe0d603f99b25 (diff)
downloadnixlib-8dfe068f862a3b2e336a246655000aa73949201d.tar
nixlib-8dfe068f862a3b2e336a246655000aa73949201d.tar.gz
nixlib-8dfe068f862a3b2e336a246655000aa73949201d.tar.bz2
nixlib-8dfe068f862a3b2e336a246655000aa73949201d.tar.lz
nixlib-8dfe068f862a3b2e336a246655000aa73949201d.tar.xz
nixlib-8dfe068f862a3b2e336a246655000aa73949201d.tar.zst
nixlib-8dfe068f862a3b2e336a246655000aa73949201d.zip
openblas: patch to fix on non-glibc
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/science/math/openblas/default.nix9
1 files changed, 8 insertions, 1 deletions
diff --git a/pkgs/development/libraries/science/math/openblas/default.nix b/pkgs/development/libraries/science/math/openblas/default.nix
index 5b3fd57551df..07d2a04c5e20 100644
--- a/pkgs/development/libraries/science/math/openblas/default.nix
+++ b/pkgs/development/libraries/science/math/openblas/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchurl, gfortran, perl, which, config, coreutils
+{ stdenv, fetchurl, fetchpatch, gfortran, perl, which, config, coreutils
 # Most packages depending on openblas expect integer width to match
 # pointer width, but some expect to use 32-bit integers always
 # (for compatibility with reference BLAS).
@@ -118,6 +118,13 @@ stdenv.mkDerivation {
     ] ++ stdenv.lib.optional (stdenv.hostPlatform.libc == "musl") "NO_AFFINITY=1"
     ++ mapAttrsToList (var: val: var + "=" + val) config;
 
+  patches = stdenv.lib.optional (stdenv.hostPlatform.libc != "glibc")
+    # https://github.com/xianyi/OpenBLAS/pull/1247
+    (fetchpatch {
+      url = "https://github.com/xianyi/OpenBLAS/commit/88a35ff457f55e527e0e8a503a0dc61976c1846d.patch";
+      sha256 = "1a3qrhvl5hp06c53fjqghq4zgf6ls7narm06l0shcvs57hznh09n";
+    });
+
   doCheck = true;
   checkTarget = "tests";