summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorPascal Wittmann <mail@pascal-wittmann.de>2014-11-11 14:20:43 +0100
committerPascal Wittmann <mail@pascal-wittmann.de>2014-11-11 14:36:34 +0100
commit8df0e0b151475350265304dfa58e9193eea0058b (patch)
treefbc44280f6dc3ea106d293ee2bbee6e3dc829057 /pkgs/development
parent0e309af732e12b23da0b36c66dbf5d7c1263e3b7 (diff)
downloadnixlib-8df0e0b151475350265304dfa58e9193eea0058b.tar
nixlib-8df0e0b151475350265304dfa58e9193eea0058b.tar.gz
nixlib-8df0e0b151475350265304dfa58e9193eea0058b.tar.bz2
nixlib-8df0e0b151475350265304dfa58e9193eea0058b.tar.lz
nixlib-8df0e0b151475350265304dfa58e9193eea0058b.tar.xz
nixlib-8df0e0b151475350265304dfa58e9193eea0058b.tar.zst
nixlib-8df0e0b151475350265304dfa58e9193eea0058b.zip
Fixed many descriptions
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/compilers/agda/stdlib.nix2
-rw-r--r--pkgs/development/compilers/opendylan/bin.nix2
-rw-r--r--pkgs/development/compilers/opendylan/default.nix2
-rw-r--r--pkgs/development/libraries/dlib/default.nix2
-rw-r--r--pkgs/development/libraries/gdcm/default.nix2
-rw-r--r--pkgs/development/libraries/gtest/default.nix2
-rw-r--r--pkgs/development/libraries/gupnp-av/default.nix2
-rw-r--r--pkgs/development/libraries/java/commons/compress/default.nix4
-rw-r--r--pkgs/development/libraries/java/commons/fileupload/default.nix4
-rw-r--r--pkgs/development/libraries/libsearpc/default.nix2
-rw-r--r--pkgs/development/libraries/libzdb/default.nix4
-rw-r--r--pkgs/development/libraries/skalibs/default.nix2
-rw-r--r--pkgs/development/lisp-modules/lisp-packages.nix4
-rw-r--r--pkgs/development/tools/golint/default.nix2
-rw-r--r--pkgs/development/tools/misc/dfu-programmer/default.nix2
-rw-r--r--pkgs/development/tools/selenium/server/default.nix2
-rw-r--r--pkgs/development/web/remarkjs/default.nix2
17 files changed, 21 insertions, 21 deletions
diff --git a/pkgs/development/compilers/agda/stdlib.nix b/pkgs/development/compilers/agda/stdlib.nix
index 638b45951c89..a583ff33cb68 100644
--- a/pkgs/development/compilers/agda/stdlib.nix
+++ b/pkgs/development/compilers/agda/stdlib.nix
@@ -18,7 +18,7 @@ agda.mkDerivation (self: rec {
 
   meta = with stdenv.lib; {
     homepage = "http://wiki.portal.chalmers.se/agda/pmwiki.php?n=Libraries.StandardLibrary";
-    description = "A standard library for use with the Agda compiler.";
+    description = "A standard library for use with the Agda compiler";
     license = stdenv.lib.licenses.mit;
     platforms = stdenv.lib.platforms.unix;
     maintainers = with maintainers; [ jwiegley fuuzetsu ];
diff --git a/pkgs/development/compilers/opendylan/bin.nix b/pkgs/development/compilers/opendylan/bin.nix
index 19f8eab482cb..4f0a1bd05129 100644
--- a/pkgs/development/compilers/opendylan/bin.nix
+++ b/pkgs/development/compilers/opendylan/bin.nix
@@ -35,7 +35,7 @@ stdenv.mkDerivation {
 
   meta = {
     homepage = http://opendylan.org;
-    description = "Dylan is a multi-paradigm functional and object-oriented programming language.";
+    description = "A multi-paradigm functional and object-oriented programming language";
     license = stdenv.lib.licenses.mit;
   };
 }
diff --git a/pkgs/development/compilers/opendylan/default.nix b/pkgs/development/compilers/opendylan/default.nix
index e4bdcf7889bb..66e62f8965e6 100644
--- a/pkgs/development/compilers/opendylan/default.nix
+++ b/pkgs/development/compilers/opendylan/default.nix
@@ -31,7 +31,7 @@ stdenv.mkDerivation {
 
   meta = {
     homepage = http://opendylan.org;
-    description = "Dylan is a multi-paradigm functional and object-oriented programming language.";
+    description = "A multi-paradigm functional and object-oriented programming language";
     license = stdenv.lib.licenses.mit;
   };
 }
diff --git a/pkgs/development/libraries/dlib/default.nix b/pkgs/development/libraries/dlib/default.nix
index 94f74e516f1b..0d262fb061e2 100644
--- a/pkgs/development/libraries/dlib/default.nix
+++ b/pkgs/development/libraries/dlib/default.nix
@@ -35,7 +35,7 @@ stdenv.mkDerivation rec {
   propagatedBuildInputs = [ x11 ];
 
   meta = with stdenv.lib; {
-    description = "Dlib is a general purpose cross-platform C++ machine learning library.";
+    description = "A general purpose cross-platform C++ machine learning library";
     homepage = http://www.dlib.net;
     license = stdenv.lib.licenses.boost;
     maintainers = with maintainers; [ christopherpoole ];
diff --git a/pkgs/development/libraries/gdcm/default.nix b/pkgs/development/libraries/gdcm/default.nix
index e100b82ae9ed..4663f7aac224 100644
--- a/pkgs/development/libraries/gdcm/default.nix
+++ b/pkgs/development/libraries/gdcm/default.nix
@@ -26,7 +26,7 @@ stdenv.mkDerivation rec {
   propagatedBuildInputs = [ ];
 
   meta = {
-    description = "The grassroots cross-platform DICOM implementation.";
+    description = "The grassroots cross-platform DICOM implementation";
     longDescription = ''
       Grassroots DICOM (GDCM) is an implementation of the DICOM standard designed to be open source so that researchers may access clinical data directly.
       GDCM includes a file format definition and a network communications protocol, both of which should be extended to provide a full set of tools for a researcher or small medical imaging vendor to interface with an existing medical database.
diff --git a/pkgs/development/libraries/gtest/default.nix b/pkgs/development/libraries/gtest/default.nix
index 787cd4066c0a..d71c29cbca5d 100644
--- a/pkgs/development/libraries/gtest/default.nix
+++ b/pkgs/development/libraries/gtest/default.nix
@@ -25,7 +25,7 @@ stdenv.mkDerivation rec {
   '';
 
   meta = with stdenv.lib; {
-    description = "Google test: Google's framework for writing C++ tests.";
+    description = "Google's framework for writing C++ tests";
     homepage = https://code.google.com/p/googletest/;
     license = licenses.bsd3;
     platforms = platforms.all;
diff --git a/pkgs/development/libraries/gupnp-av/default.nix b/pkgs/development/libraries/gupnp-av/default.nix
index 3cbb13972d35..2dcd5b11c386 100644
--- a/pkgs/development/libraries/gupnp-av/default.nix
+++ b/pkgs/development/libraries/gupnp-av/default.nix
@@ -13,7 +13,7 @@ stdenv.mkDerivation rec {
 
   meta = {
     homepage = http://gupnp.org/;
-    description = "GUPnP-AV is a collection of helpers for building AV (audio/video) applications using GUPnP.";
+    description = "A collection of helpers for building AV (audio/video) applications using GUPnP";
     longDescription = "GUPnP implements the UPnP specification: resource announcement and discovery, description, control, event notification, and presentation (GUPnP includes basic web server functionality through libsoup). GUPnP does not include helpers for construction or control of specific standardized resources (e.g. MediaServer); this is left for higher level libraries utilizing the GUPnP framework.";
     license = stdenv.lib.licenses.gpl2;
     platforms = stdenv.lib.platforms.linux;
diff --git a/pkgs/development/libraries/java/commons/compress/default.nix b/pkgs/development/libraries/java/commons/compress/default.nix
index 2c20d9a9b362..4e04ba47c858 100644
--- a/pkgs/development/libraries/java/commons/compress/default.nix
+++ b/pkgs/development/libraries/java/commons/compress/default.nix
@@ -16,8 +16,8 @@ stdenv.mkDerivation rec {
   '';
 
   meta = {
-    homepage    = "http://commons.apache.org/proper/commons-compress";
-    description = "Allows manipulation of ar, cpio, Unix dump, tar, zip, gzip, XZ, Pack200, bzip2, 7z, arj, lzma, snappy, DEFLATE and Z files.";
+    homepage    = http://commons.apache.org/proper/commons-compress;
+    description = "Allows manipulation of ar, cpio, Unix dump, tar, zip, gzip, XZ, Pack200, bzip2, 7z, arj, lzma, snappy, DEFLATE and Z files";
     maintainers = with stdenv.lib.maintainers; [ copumpkin ];
     license     = stdenv.lib.licenses.asl20;
   };
diff --git a/pkgs/development/libraries/java/commons/fileupload/default.nix b/pkgs/development/libraries/java/commons/fileupload/default.nix
index ebb8a7d7f9db..2018e3f11f2d 100644
--- a/pkgs/development/libraries/java/commons/fileupload/default.nix
+++ b/pkgs/development/libraries/java/commons/fileupload/default.nix
@@ -15,8 +15,8 @@ stdenv.mkDerivation rec {
   '';
 
   meta = {
-    homepage    = "http://commons.apache.org/proper/commons-fileupload";
-    description = "Makes it easy to add robust, high-performance, file upload capability to your servlets and web applications.";
+    homepage    = http://commons.apache.org/proper/commons-fileupload;
+    description = "Makes it easy to add robust, high-performance, file upload capability to your servlets and web applications";
     maintainers = with stdenv.lib.maintainers; [ copumpkin ];
     license     = stdenv.lib.licenses.asl20;
   };
diff --git a/pkgs/development/libraries/libsearpc/default.nix b/pkgs/development/libraries/libsearpc/default.nix
index 32cb7b860c4e..d33ca9a15edd 100644
--- a/pkgs/development/libraries/libsearpc/default.nix
+++ b/pkgs/development/libraries/libsearpc/default.nix
@@ -24,7 +24,7 @@ stdenv.mkDerivation rec
   meta =
   {
     homepage = "https://github.com/haiwen/libsearpc";
-    description = "A simple and easy-to-use C language RPC framework (including both server side & client side) based on GObject System.";
+    description = "A simple and easy-to-use C language RPC framework (including both server side & client side) based on GObject System";
     license = stdenv.lib.licenses.lgpl3;
     platforms = stdenv.lib.platforms.linux;
     maintainers = [ stdenv.lib.maintainers.calrama ];
diff --git a/pkgs/development/libraries/libzdb/default.nix b/pkgs/development/libraries/libzdb/default.nix
index 90692569f089..a5799f79b56b 100644
--- a/pkgs/development/libraries/libzdb/default.nix
+++ b/pkgs/development/libraries/libzdb/default.nix
@@ -15,8 +15,8 @@ stdenv.mkDerivation rec
 
   meta =
   {
-    homepage = "http://www.tildeslash.com/libzdb/";
-    description = "A small, easy to use Open Source Database Connection Pool Library.";
+    homepage = http://www.tildeslash.com/libzdb/;
+    description = "A small, easy to use Open Source Database Connection Pool Library";
     license = stdenv.lib.licenses.gpl3;
     platforms = stdenv.lib.platforms.linux;
     maintainers = [ stdenv.lib.maintainers.calrama ];
diff --git a/pkgs/development/libraries/skalibs/default.nix b/pkgs/development/libraries/skalibs/default.nix
index 842d74848df6..ba8dcc812e83 100644
--- a/pkgs/development/libraries/skalibs/default.nix
+++ b/pkgs/development/libraries/skalibs/default.nix
@@ -50,7 +50,7 @@ in stdenv.mkDerivation rec {
 
   meta = {
     homepage = http://skarnet.org/software/skalibs/;
-    description = "A set of general-purpose C programming libraries.";
+    description = "A set of general-purpose C programming libraries";
     platforms = stdenv.lib.platforms.all;
     license = stdenv.lib.licenses.isc;
   };
diff --git a/pkgs/development/lisp-modules/lisp-packages.nix b/pkgs/development/lisp-modules/lisp-packages.nix
index 0d9383a465fd..2b4cda88ef81 100644
--- a/pkgs/development/lisp-modules/lisp-packages.nix
+++ b/pkgs/development/lisp-modules/lisp-packages.nix
@@ -48,7 +48,7 @@ let lispPackages = rec {
   alexandria = buildLispPackage rec {
     baseName = "alexandria";
     version = "git-20131029";
-    description = "Alexandria is a collection of portable public domain utilities.";
+    description = "A collection of portable public domain utilities";
     deps = [];
     src = pkgs.fetchgit {
       url = "git://common-lisp.net/projects/alexandria/alexandria.git";
@@ -88,7 +88,7 @@ let lispPackages = rec {
   esrap = buildLispPackage rec {
     baseName = "esrap";
     version = "git-20131029";
-    description = "A Packrat / Parsing Grammar / TDPL parser for Common Lisp.";
+    description = "A Packrat / Parsing Grammar / TDPL parser for Common Lisp";
     deps = [alexandria];
     src = pkgs.fetchgit {
       url = "https://github.com/scymtym/esrap.git";
diff --git a/pkgs/development/tools/golint/default.nix b/pkgs/development/tools/golint/default.nix
index 9e82580018fc..b9292f6fa117 100644
--- a/pkgs/development/tools/golint/default.nix
+++ b/pkgs/development/tools/golint/default.nix
@@ -20,7 +20,7 @@ stdenv.mkDerivation rec {
   '';
 
   meta = with lib; {
-    description = "Linter for Go source code.";
+    description = "Linter for Go source code";
     homepage = https://github.com/golang/lint;
     license = licenses.mit;
     maintainers = with maintainers; [ offline ];
diff --git a/pkgs/development/tools/misc/dfu-programmer/default.nix b/pkgs/development/tools/misc/dfu-programmer/default.nix
index 2df687b8bc6b..577bd6f01f56 100644
--- a/pkgs/development/tools/misc/dfu-programmer/default.nix
+++ b/pkgs/development/tools/misc/dfu-programmer/default.nix
@@ -16,7 +16,7 @@ stdenv.mkDerivation rec {
 
   meta = with stdenv.lib; {
     license = licenses.gpl2;
-    description = "A Device Firmware Update based USB programmer for Atmel chips with a USB bootloader.";
+    description = "A Device Firmware Update based USB programmer for Atmel chips with a USB bootloader";
     homepage = http://dfu-programmer.sourceforge.net/;
     maintainers = [ maintainers.the-kenny ];
   };
diff --git a/pkgs/development/tools/selenium/server/default.nix b/pkgs/development/tools/selenium/server/default.nix
index ebbcd2c8fd87..0c3331653078 100644
--- a/pkgs/development/tools/selenium/server/default.nix
+++ b/pkgs/development/tools/selenium/server/default.nix
@@ -44,7 +44,7 @@ in stdenv.mkDerivation rec {
 
   meta = {
     homepage = https://code.google.com/p/selenium;
-    description = "Selenium Server for remote WebDriver.";
+    description = "Selenium Server for remote WebDriver";
     maintainers = with maintainers; [ coconnor offline ];
     platforms = platforms.all;
     license = licenses.asl20;
diff --git a/pkgs/development/web/remarkjs/default.nix b/pkgs/development/web/remarkjs/default.nix
index bebf2d80caad..153b165da1e5 100644
--- a/pkgs/development/web/remarkjs/default.nix
+++ b/pkgs/development/web/remarkjs/default.nix
@@ -58,7 +58,7 @@ in stdenv.mkDerivation rec {
 
   meta = {
     homepage = http://remarkjs.com;
-    description = "A simple, in-browser, markdown-driven slideshow tool.";
+    description = "A simple, in-browser, markdown-driven slideshow tool";
     maintainers = [ stdenv.lib.maintainers.rickynils ];
     platforms = stdenv.lib.platforms.linux;
     license = stdenv.lib.licenses.mit;