summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2009-07-17 18:06:28 +0000
committerLudovic Courtès <ludo@gnu.org>2009-07-17 18:06:28 +0000
commit8cbb8848a9a0b4f492807ec7170b24a4cca57dea (patch)
tree9b2374f6e63e6056faa9edac038421e6ff0dc98e /pkgs/development
parent1dfef7863364a19b31f546a2a9ff338a11a16beb (diff)
downloadnixlib-8cbb8848a9a0b4f492807ec7170b24a4cca57dea.tar
nixlib-8cbb8848a9a0b4f492807ec7170b24a4cca57dea.tar.gz
nixlib-8cbb8848a9a0b4f492807ec7170b24a4cca57dea.tar.bz2
nixlib-8cbb8848a9a0b4f492807ec7170b24a4cca57dea.tar.lz
nixlib-8cbb8848a9a0b4f492807ec7170b24a4cca57dea.tar.xz
nixlib-8cbb8848a9a0b4f492807ec7170b24a4cca57dea.tar.zst
nixlib-8cbb8848a9a0b4f492807ec7170b24a4cca57dea.zip
GCJ 4.4: Move `ecj.jar' out of the `src' attribute.
svn path=/nixpkgs/trunk/; revision=16417
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/compilers/gcc-4.4/builder.sh6
-rw-r--r--pkgs/development/compilers/gcc-4.4/default.nix23
2 files changed, 19 insertions, 10 deletions
diff --git a/pkgs/development/compilers/gcc-4.4/builder.sh b/pkgs/development/compilers/gcc-4.4/builder.sh
index d40b9de2f7d6..d36ffe81aae1 100644
--- a/pkgs/development/compilers/gcc-4.4/builder.sh
+++ b/pkgs/development/compilers/gcc-4.4/builder.sh
@@ -62,6 +62,12 @@ fi
 
 
 preConfigure() {
+    # Copy `ecj.jar' to `$(top_srcdir)' when available.
+    if [ -f "$javaEcj" ]
+    then
+	cp -v "$javaEcj" "ecj.jar"
+    fi
+
     # Perform the build in a different directory.
     mkdir ../build
     cd ../build
diff --git a/pkgs/development/compilers/gcc-4.4/default.nix b/pkgs/development/compilers/gcc-4.4/default.nix
index 7d09cc9e2980..2b26b9b01a32 100644
--- a/pkgs/development/compilers/gcc-4.4/default.nix
+++ b/pkgs/development/compilers/gcc-4.4/default.nix
@@ -45,16 +45,6 @@ stdenv.mkDerivation ({
     optional langJava (fetchurl {
       url = "mirror://gcc/releases/gcc-${version}/gcc-java-${version}.tar.bz2";
       sha256 = "0i60llrllgm4sbplw2rc9b0gi0mxr88la07a72mvlbblzpxn22hb";
-    }) ++
-
-    optional langJava (fetchurl {
-      # The `$(top_srcdir)/ecj.jar' file is automatically picked up at
-      # `configure' time.
-
-      # XXX: Eventually we might want to take it from upstream.
-      url = "ftp://sourceware.org/pub/java/ecj-4.3.jar";
-      name = "ecj.jar";
-      sha256 = "0jz7hvc0s6iydmhgh5h2m15yza7p2rlss2vkif30vm9y77m97qcx";
     });
 
   patches =
@@ -62,6 +52,19 @@ stdenv.mkDerivation ({
     ++ optional noSysDirs ./no-sys-dirs.patch
     ++ optional (noSysDirs && langFortran) ./no-sys-dirs-fortran.patch;
 
+  javaEcj =
+    if langJava
+    then fetchurl {
+        # The `$(top_srcdir)/ecj.jar' file is automatically picked up at
+        # `configure' time.
+
+        # XXX: Eventually we might want to take it from upstream.
+        url = "ftp://sourceware.org/pub/java/ecj-4.3.jar";
+        sha256 = "0jz7hvc0s6iydmhgh5h2m15yza7p2rlss2vkif30vm9y77m97qcx";
+      }
+    else "";
+
+
   inherit noSysDirs profiledCompiler staticCompiler;
 
   buildInputs = [ texinfo gmp mpfr gettext ]