summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorzimbatm <zimbatm@zimbatm.com>2016-02-26 18:00:44 +0000
committerzimbatm <zimbatm@zimbatm.com>2016-02-26 18:00:44 +0000
commit8b4edf10cf81e47b8ce43b42ad7e24bf00b0b697 (patch)
treeed3fe35a2b17a59f626ae22c68521b28757802b4 /pkgs/development
parent53ea7dee75b90181683c59869940db85cabc2d78 (diff)
parentaccc1f1484ad6721d03063d148ea46c85dc76a68 (diff)
downloadnixlib-8b4edf10cf81e47b8ce43b42ad7e24bf00b0b697.tar
nixlib-8b4edf10cf81e47b8ce43b42ad7e24bf00b0b697.tar.gz
nixlib-8b4edf10cf81e47b8ce43b42ad7e24bf00b0b697.tar.bz2
nixlib-8b4edf10cf81e47b8ce43b42ad7e24bf00b0b697.tar.lz
nixlib-8b4edf10cf81e47b8ce43b42ad7e24bf00b0b697.tar.xz
nixlib-8b4edf10cf81e47b8ce43b42ad7e24bf00b0b697.tar.zst
nixlib-8b4edf10cf81e47b8ce43b42ad7e24bf00b0b697.zip
Merge pull request #13144 from zimbatm/go-ssl-cleanup
go: remove ssl certs patches
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/compilers/go/1.4.nix3
-rw-r--r--pkgs/development/compilers/go/1.5.nix1
-rw-r--r--pkgs/development/compilers/go/cacert-1.4.patch14
-rw-r--r--pkgs/development/compilers/go/cacert-1.5.patch8
4 files changed, 2 insertions, 24 deletions
diff --git a/pkgs/development/compilers/go/1.4.nix b/pkgs/development/compilers/go/1.4.nix
index d25001697443..9c6bbba24d5d 100644
--- a/pkgs/development/compilers/go/1.4.nix
+++ b/pkgs/development/compilers/go/1.4.nix
@@ -46,6 +46,8 @@ stdenv.mkDerivation rec {
     sed -i 's,/bin/pwd,'"`type -P pwd`", src/os/os_test.go
     # Disable the unix socket test
     sed -i '/TestShutdownUnix/areturn' src/net/net_test.go
+    # Disable network timeout test
+    sed -i '/TestDialTimeout/areturn' src/net/dial_test.go
     # Disable the hostname test
     sed -i '/TestHostname/areturn' src/os/os_test.go
     # ParseInLocation fails the test
@@ -84,7 +86,6 @@ stdenv.mkDerivation rec {
   '';
 
   patches = [
-    ./cacert-1.4.patch
     ./remove-tools-1.4.patch
   ];
 
diff --git a/pkgs/development/compilers/go/1.5.nix b/pkgs/development/compilers/go/1.5.nix
index 54c8cf219d5f..b5bfac850280 100644
--- a/pkgs/development/compilers/go/1.5.nix
+++ b/pkgs/development/compilers/go/1.5.nix
@@ -89,7 +89,6 @@ stdenv.mkDerivation rec {
   '';
 
   patches = [
-    ./cacert-1.5.patch
     ./remove-tools-1.5.patch
   ]
   # -ldflags=-s is required to compile on Darwin, see
diff --git a/pkgs/development/compilers/go/cacert-1.4.patch b/pkgs/development/compilers/go/cacert-1.4.patch
deleted file mode 100644
index 5346d3f39505..000000000000
--- a/pkgs/development/compilers/go/cacert-1.4.patch
+++ /dev/null
@@ -1,14 +0,0 @@
-Go comes with hardcoded cacert. We add the usual in NixOS,
-for easier NixOS life.
-
-diff -r 14854533dcc7 src/crypto/x509/root_unix.go
---- a/src/crypto/x509/root_unix.go	Thu Dec 11 11:27:56 2014 +1100
-+++ b/src/crypto/x509/root_unix.go	Tue Jan 06 00:41:31 2015 -0600
-@@ -17,6 +17,7 @@
- 	"/usr/local/share/certs/ca-root-nss.crt", // FreeBSD/DragonFly
- 	"/etc/pki/tls/cacert.pem",                // OpenELEC
- 	"/etc/certs/ca-certificates.crt",         // Solaris 11.2+
-+	"/etc/ssl/certs/ca-bundle.crt",           // NixOS
- }
- 
- // Possible directories with certificate files; stop after successfully
diff --git a/pkgs/development/compilers/go/cacert-1.5.patch b/pkgs/development/compilers/go/cacert-1.5.patch
deleted file mode 100644
index 32c322a104e6..000000000000
--- a/pkgs/development/compilers/go/cacert-1.5.patch
+++ /dev/null
@@ -1,8 +0,0 @@
---- a/src/crypto/x509/root_linux.go	2015-08-19 23:06:11.115133174 +0200
-+++ b/src/crypto/x509/root_linux.go	2015-08-19 23:07:04.238507161 +0200
-@@ -10,4 +10,5 @@
- 	"/etc/pki/tls/certs/ca-bundle.crt",   // Fedora/RHEL
- 	"/etc/ssl/ca-bundle.pem",             // OpenSUSE
- 	"/etc/pki/tls/cacert.pem",            // OpenELEC
-+	"/etc/ssl/certs/ca-bundle.crt",       // NixOS
- }