summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorMichael Raskin <7c6f434c@mail.ru>2011-04-13 05:47:51 +0000
committerMichael Raskin <7c6f434c@mail.ru>2011-04-13 05:47:51 +0000
commit8a00dfcc189198b7e2f64725e74b77c117a04d16 (patch)
tree9ad271bc6834dfd721a2e06b12ac8fd7113aa087 /pkgs/development
parent13a1c3a69b0d2d312a2d2ff7295a25cf5197a389 (diff)
downloadnixlib-8a00dfcc189198b7e2f64725e74b77c117a04d16.tar
nixlib-8a00dfcc189198b7e2f64725e74b77c117a04d16.tar.gz
nixlib-8a00dfcc189198b7e2f64725e74b77c117a04d16.tar.bz2
nixlib-8a00dfcc189198b7e2f64725e74b77c117a04d16.tar.lz
nixlib-8a00dfcc189198b7e2f64725e74b77c117a04d16.tar.xz
nixlib-8a00dfcc189198b7e2f64725e74b77c117a04d16.tar.zst
nixlib-8a00dfcc189198b7e2f64725e74b77c117a04d16.zip
Update teeworlds
svn path=/nixpkgs/trunk/; revision=26814
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/tools/build-managers/bam/default.nix63
1 files changed, 63 insertions, 0 deletions
diff --git a/pkgs/development/tools/build-managers/bam/default.nix b/pkgs/development/tools/build-managers/bam/default.nix
new file mode 100644
index 000000000000..ef5aed1f26ed
--- /dev/null
+++ b/pkgs/development/tools/build-managers/bam/default.nix
@@ -0,0 +1,63 @@
+x@{builderDefsPackage
+  , lua5, python
+  , ...}:
+builderDefsPackage
+(a :  
+let 
+  helperArgNames = ["stdenv" "fetchurl" "builderDefsPackage"] ++ 
+    [];
+
+  buildInputs = map (n: builtins.getAttr n x)
+    (builtins.attrNames (builtins.removeAttrs x helperArgNames));
+  sourceInfo = rec {
+    baseName="bam";
+    version="0.4.0";
+    name="${baseName}-${version}";
+    url="http://github.com/downloads/matricks/bam/${name}.tar.bz2";
+    hash="0z90wvyd4nfl7mybdrv9dsd4caaikc6fxw801b72gqi1m9q0c0sn";
+  };
+in
+rec {
+  src = a.fetchurl {
+    url = sourceInfo.url;
+    sha256 = sourceInfo.hash;
+  };
+
+  inherit (sourceInfo) name version;
+  inherit buildInputs;
+
+  /* doConfigure should be removed if not needed */
+  phaseNames = ["check" "doDeploy"];
+
+  build = a.fullDepEntry ''
+    sh make_unix.sh
+  '' ["minInit" "doUnpack" "addInputs"];
+
+  check = a.fullDepEntry ''
+    python scripts/test.py
+  '' ["build" "addInputs"];
+
+  doDeploy = a.fullDepEntry ''
+    ensureDir "$out/share/bam"
+    cp -r docs examples tests  "$out/share/bam"
+    ensureDir "$out/bin"
+    cp bam "$out/bin"
+  '' ["minInit" "defEnsureDir" "build"];
+      
+  meta = {
+    description = "Yet another build manager";
+    maintainers = with a.lib.maintainers;
+    [
+      raskin
+    ];
+    platforms = with a.lib.platforms;
+      linux;
+    license = "free-noncopyleft";
+  };
+  passthru = {
+    updateInfo = {
+      downloadPage = "http://matricks.github.com/bam/";
+    };
+  };
+}) x
+