summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorWill Dietz <w@wdtz.org>2018-04-30 17:43:54 -0500
committerWill Dietz <w@wdtz.org>2018-04-30 18:08:48 -0500
commit855e0463abe182e4cb481db8246ae5cd029c1298 (patch)
treed4d825e995a2e79ce19ebb1e1dd5efc8a3859213 /pkgs/development
parenta2c94b7f5c894a21c268623b4938b039b57a02f1 (diff)
downloadnixlib-855e0463abe182e4cb481db8246ae5cd029c1298.tar
nixlib-855e0463abe182e4cb481db8246ae5cd029c1298.tar.gz
nixlib-855e0463abe182e4cb481db8246ae5cd029c1298.tar.bz2
nixlib-855e0463abe182e4cb481db8246ae5cd029c1298.tar.lz
nixlib-855e0463abe182e4cb481db8246ae5cd029c1298.tar.xz
nixlib-855e0463abe182e4cb481db8246ae5cd029c1298.tar.zst
nixlib-855e0463abe182e4cb481db8246ae5cd029c1298.zip
tree-wide: platforms = platforms.gnu; -> platforms = gnu ++ linux
"platforms.gnu" has been linux-only since at least 17.03:

$ nix eval -f channel:nixos-17.03 lib.platforms.gnu
[ "i686-linux" "x86_64-linux" "armv5tel-linux" "armv6l-linux" "armv7l-linux" "aarch64-linux" "mips64el-linux" ]

Unlike platforms.linux, platforms.gnu indicates "must use glibc"
which for the most part is not intended.

Replacing platforms.gnu with platforms.linux would be the same "today"
but let's err on preserving existing behavior and be optimistic
about platforms these packages work on.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/guile-modules/guile-lib/default.nix2
-rw-r--r--pkgs/development/guile-modules/guile-ncurses/default.nix2
-rw-r--r--pkgs/development/libraries/libchamplain/default.nix2
-rw-r--r--pkgs/development/libraries/libchop/default.nix2
-rw-r--r--pkgs/development/libraries/vcdimager/default.nix2
5 files changed, 5 insertions, 5 deletions
diff --git a/pkgs/development/guile-modules/guile-lib/default.nix b/pkgs/development/guile-modules/guile-lib/default.nix
index 95741e07600a..35eb4667bd6b 100644
--- a/pkgs/development/guile-modules/guile-lib/default.nix
+++ b/pkgs/development/guile-modules/guile-lib/default.nix
@@ -40,6 +40,6 @@ in stdenv.mkDerivation {
     homepage = "http://www.nongnu.org/guile-lib/";
     license = licenses.gpl3Plus;
     maintainers = with maintainers; [ vyp ];
-    platforms = platforms.gnu;
+    platforms = platforms.gnu ++ platforms.linux;
   };
 }
diff --git a/pkgs/development/guile-modules/guile-ncurses/default.nix b/pkgs/development/guile-modules/guile-ncurses/default.nix
index 152a34883045..8f6018582670 100644
--- a/pkgs/development/guile-modules/guile-ncurses/default.nix
+++ b/pkgs/development/guile-modules/guile-ncurses/default.nix
@@ -39,6 +39,6 @@ in stdenv.mkDerivation {
     homepage = "https://www.gnu.org/software/guile-ncurses/";
     license = licenses.lgpl3Plus;
     maintainers = with maintainers; [ vyp ];
-    platforms = platforms.gnu;
+    platforms = platforms.gnu ++ platforms.linux;
   };
 }
diff --git a/pkgs/development/libraries/libchamplain/default.nix b/pkgs/development/libraries/libchamplain/default.nix
index 74e5bbc952ae..418e9cf0b573 100644
--- a/pkgs/development/libraries/libchamplain/default.nix
+++ b/pkgs/development/libraries/libchamplain/default.nix
@@ -38,6 +38,6 @@ stdenv.mkDerivation rec {
     '';
 
      maintainers = gnome3.maintainers;
-     platforms = platforms.gnu;  # arbitrary choice
+     platforms = platforms.gnu ++ platforms.linux;  # arbitrary choice
   };
 }
diff --git a/pkgs/development/libraries/libchop/default.nix b/pkgs/development/libraries/libchop/default.nix
index 1be3a74fbff5..5790672d8e51 100644
--- a/pkgs/development/libraries/libchop/default.nix
+++ b/pkgs/development/libraries/libchop/default.nix
@@ -50,6 +50,6 @@ stdenv.mkDerivation rec {
     homepage = http://nongnu.org/libchop/;
     license = licenses.gpl3Plus;
     maintainers = with maintainers; [ viric ];
-    platforms = platforms.gnu;
+    platforms = platforms.gnu ++ platforms.linux;
   };
 }
diff --git a/pkgs/development/libraries/vcdimager/default.nix b/pkgs/development/libraries/vcdimager/default.nix
index 48ad33424f60..77956be3b12e 100644
--- a/pkgs/development/libraries/vcdimager/default.nix
+++ b/pkgs/development/libraries/vcdimager/default.nix
@@ -17,7 +17,7 @@ stdenv.mkDerivation rec {
   meta = with lib; {
     homepage = http://www.gnu.org/software/vcdimager/;
     description = "Full-featured mastering suite for authoring, disassembling and analyzing Video CDs and Super Video CDs";
-    platforms = platforms.gnu; # random choice
+    platforms = platforms.gnu ++ platforms.linux; # random choice
     license = licenses.gpl2;
   };
 }