summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorJan Tojnar <jtojnar@gmail.com>2018-06-21 11:13:59 +0200
committerJan Tojnar <jtojnar@gmail.com>2018-06-29 04:37:35 +0200
commit84fc0622cf4bfa1660b83b0b65f02cd9e7a460d4 (patch)
tree5d95ec91367a9fea58142334309fa8d7f4fbcf25 /pkgs/development
parentdd3d7f5a5dc5ccae908f06ba9bc0b3e136feef5a (diff)
downloadnixlib-84fc0622cf4bfa1660b83b0b65f02cd9e7a460d4.tar
nixlib-84fc0622cf4bfa1660b83b0b65f02cd9e7a460d4.tar.gz
nixlib-84fc0622cf4bfa1660b83b0b65f02cd9e7a460d4.tar.bz2
nixlib-84fc0622cf4bfa1660b83b0b65f02cd9e7a460d4.tar.lz
nixlib-84fc0622cf4bfa1660b83b0b65f02cd9e7a460d4.tar.xz
nixlib-84fc0622cf4bfa1660b83b0b65f02cd9e7a460d4.tar.zst
nixlib-84fc0622cf4bfa1660b83b0b65f02cd9e7a460d4.zip
volume_key: split out python bindings
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/volume-key/default.nix7
1 files changed, 6 insertions, 1 deletions
diff --git a/pkgs/development/libraries/volume-key/default.nix b/pkgs/development/libraries/volume-key/default.nix
index 53faf07623e9..4dd01f664d19 100644
--- a/pkgs/development/libraries/volume-key/default.nix
+++ b/pkgs/development/libraries/volume-key/default.nix
@@ -13,7 +13,7 @@ in stdenv.mkDerivation rec {
     sha256 = "16qdi5s6ycsh0iyc362gly7ggrwamky8i0zgbd4ajp3ymk9vqdva";
   };
 
-  outputs = [ "out" "man" "dev" ];
+  outputs = [ "out" "man" "dev" "py" ];
 
   nativeBuildInputs = [ autoreconfHook pkgconfig gettext python2 swig ];
 
@@ -28,6 +28,11 @@ in stdenv.mkDerivation rec {
     })
   ];
 
+  makeFlags = [
+    "pyexecdir=$(py)/${python2.sitePackages}"
+    "pythondir=$(py)/${python2.sitePackages}"
+  ];
+
   meta = with stdenv.lib; {
     description = "A library for manipulating storage volume encryption keys and storing them separately from volumes to handle forgotten passphrases, and the associated command-line tool";
     homepage = https://pagure.io/volume_key/;