summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2018-08-28 08:41:06 +0100
committerGitHub <noreply@github.com>2018-08-28 08:41:06 +0100
commit849fb28cf35024fb8518535123fcc93a5bc087dd (patch)
treef4e2a70760b8a35ad32fcd17995bf19c6702a61d /pkgs/development
parentb4c9f8d0358af4af102714e1a8fda0ee60ffa801 (diff)
parent2ed25d3768b78faf1f6b90f5adb5e62ef15f75ff (diff)
downloadnixlib-849fb28cf35024fb8518535123fcc93a5bc087dd.tar
nixlib-849fb28cf35024fb8518535123fcc93a5bc087dd.tar.gz
nixlib-849fb28cf35024fb8518535123fcc93a5bc087dd.tar.bz2
nixlib-849fb28cf35024fb8518535123fcc93a5bc087dd.tar.lz
nixlib-849fb28cf35024fb8518535123fcc93a5bc087dd.tar.xz
nixlib-849fb28cf35024fb8518535123fcc93a5bc087dd.tar.zst
nixlib-849fb28cf35024fb8518535123fcc93a5bc087dd.zip
Merge pull request #45693 from aneeshusa/mark-bundler-as-system-plugin-for-vagrant
vagrant: mark bundler as system plugin
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/tools/vagrant/default.nix1
-rw-r--r--pkgs/development/tools/vagrant/use-system-bundler-version.patch13
2 files changed, 14 insertions, 0 deletions
diff --git a/pkgs/development/tools/vagrant/default.nix b/pkgs/development/tools/vagrant/default.nix
index fe75c9fd2085..f247a20b1b27 100644
--- a/pkgs/development/tools/vagrant/default.nix
+++ b/pkgs/development/tools/vagrant/default.nix
@@ -38,6 +38,7 @@ in buildRubyGem rec {
 
   patches = [
     ./unofficial-installation-nowarn.patch
+    ./use-system-bundler-version.patch
   ];
 
   # PATH additions:
diff --git a/pkgs/development/tools/vagrant/use-system-bundler-version.patch b/pkgs/development/tools/vagrant/use-system-bundler-version.patch
new file mode 100644
index 000000000000..c386acf4a1c7
--- /dev/null
+++ b/pkgs/development/tools/vagrant/use-system-bundler-version.patch
@@ -0,0 +1,13 @@
+diff --git i/lib/vagrant/bundler.rb w/lib/vagrant/bundler.rb
+index 301e40e37..e361ab510 100644
+--- i/lib/vagrant/bundler.rb
++++ w/lib/vagrant/bundler.rb
+@@ -217,7 +217,7 @@ module Vagrant
+       source_list = {}
+       system_plugins = plugins.map do |plugin_name, plugin_info|
+         plugin_name if plugin_info["system"]
+-      end.compact
++      end.compact << "bundler"
+       installer_set = VagrantSet.new(:both)
+       installer_set.system_plugins = system_plugins
+