summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorDan Peebles <pumpkin@me.com>2017-05-22 12:22:03 -0400
committerDan Peebles <pumpkin@me.com>2017-05-22 12:22:13 -0400
commit845d1b28bf57d3f1eb016a323cf15808c0fbfd85 (patch)
tree0558e9d8afbabb80237064f9b5773d9dc4b7b02e /pkgs/development
parentaa73b7df307c78cf24c20a90d118928eca4d235c (diff)
downloadnixlib-845d1b28bf57d3f1eb016a323cf15808c0fbfd85.tar
nixlib-845d1b28bf57d3f1eb016a323cf15808c0fbfd85.tar.gz
nixlib-845d1b28bf57d3f1eb016a323cf15808c0fbfd85.tar.bz2
nixlib-845d1b28bf57d3f1eb016a323cf15808c0fbfd85.tar.lz
nixlib-845d1b28bf57d3f1eb016a323cf15808c0fbfd85.tar.xz
nixlib-845d1b28bf57d3f1eb016a323cf15808c0fbfd85.tar.zst
nixlib-845d1b28bf57d3f1eb016a323cf15808c0fbfd85.zip
pants{,13-pre}: move from pythonPackages to top level
That means it'll build in Hydra and we don't really care which version of
Python it builds against.
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/tools/build-managers/pants/default.nix95
1 files changed, 95 insertions, 0 deletions
diff --git a/pkgs/development/tools/build-managers/pants/default.nix b/pkgs/development/tools/build-managers/pants/default.nix
new file mode 100644
index 000000000000..575012f27e8f
--- /dev/null
+++ b/pkgs/development/tools/build-managers/pants/default.nix
@@ -0,0 +1,95 @@
+{ stdenv, pythonPackages }:
+
+with stdenv.lib;
+with pythonPackages;
+
+let
+  # Get rid of this when pants 1.3.0 is released and make 0.5 the default
+  pathspec = buildPythonApplication rec {
+    pname   = "pathspec";
+    version = "0.3.4";
+    name    = "${pname}-${version}";
+
+    src = fetchPypi {
+      inherit pname version;
+      sha256 = "0a37yrr2jhlg8aiynxivh2xqani7l9j725qxzrm7cm7m4rfcl1bn";
+    };
+
+    meta = {
+      description = "Utility library for gitignore-style pattern matching of file paths";
+      homepage = "https://github.com/cpburnz/python-path-specification";
+      license = licenses.mpl20;
+     maintainers = with maintainers; [ copumpkin ];
+    };
+  };
+in {
+  pants =
+    pythonPackages.buildPythonPackage rec {
+    pname   = "pantsbuild.pants";
+    version = "1.2.1";
+    name    = "${pname}-${version}";
+
+    src = fetchPypi {
+      inherit pname version;
+      sha256 = "1bnzhhd2acwk7ckv56xzg2d9vxacl3k5bh13bsjxymnq3spm962w";
+    };
+
+    prePatch = ''
+      sed -E -i "s/'([[:alnum:].-]+)[=><][^']*'/'\\1'/g" setup.py
+    '';
+
+    # Unnecessary, and causes some really weird behavior around .class files, which
+    # this package bundles. See https://github.com/NixOS/nixpkgs/issues/22520.
+    dontStrip = true;
+
+    propagatedBuildInputs = [
+      ansicolors beautifulsoup4 cffi coverage docutils fasteners futures
+      isort lmdb markdown mock packaging pathspec pep8 pex psutil pyflakes
+      pygments pystache pytestcov pytest pywatchman requests scandir
+      setproctitle setuptools six thrift wheel twitter-common-dirutil
+      twitter-common-confluence twitter-common-collections
+    ];
+
+    meta = {
+      description = "A build system for software projects in a variety of languages";
+      homepage    = "http://www.pantsbuild.org/";
+      license     = licenses.asl20;
+      maintainers = with maintainers; [ copumpkin ];
+      platforms   = platforms.unix;
+    };
+  };
+
+  pants13-pre = buildPythonApplication rec {
+    pname   = "pantsbuild.pants";
+    version = "1.3.0.dev19";
+    name    = "${pname}-${version}";
+
+    src = fetchPypi {
+      inherit pname version;
+      sha256 = "07gxx8kzkcx3pm2qd5sz2xb3nw9khvbapiqdzgjvzbvai2gsd5qq";
+    };
+
+    prePatch = ''
+      sed -E -i "s/'([[:alnum:].-]+)[=><][[:digit:]=><.,]*'/'\\1'/g" setup.py
+    '';
+
+    # Unnecessary, and causes some really weird behavior around .class files, which
+    # this package bundles. See https://github.com/NixOS/nixpkgs/issues/22520.
+    dontStrip = true;
+
+    propagatedBuildInputs = [
+      twitter-common-collections setproctitle setuptools six ansicolors
+      packaging pathspec scandir twitter-common-dirutil psutil requests
+      pystache pex docutils markdown pygments twitter-common-confluence
+      fasteners coverage pywatchman futures cffi
+    ];
+
+    meta = {
+      description = "A build system for software projects in a variety of languages";
+      homepage    = "http://www.pantsbuild.org/";
+      license     = licenses.asl20;
+      maintainers = with maintainers; [ copumpkin ];
+      platforms   = platforms.unix;
+    };
+  };
+}