summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorAlex Brandt <alunduil@alunduil.com>2017-08-23 22:57:28 -0500
committerFrederik Rietdijk <fridh@fridh.nl>2017-09-07 09:28:03 +0200
commit83dbb41aed4033318eb83f3897a22816a6943a14 (patch)
tree4acf56ccd4c35c9cbab61c96be661d25eddcc350 /pkgs/development
parentf06d7bd1251e69c746761011f21ad849316f550f (diff)
downloadnixlib-83dbb41aed4033318eb83f3897a22816a6943a14.tar
nixlib-83dbb41aed4033318eb83f3897a22816a6943a14.tar.gz
nixlib-83dbb41aed4033318eb83f3897a22816a6943a14.tar.bz2
nixlib-83dbb41aed4033318eb83f3897a22816a6943a14.tar.lz
nixlib-83dbb41aed4033318eb83f3897a22816a6943a14.tar.xz
nixlib-83dbb41aed4033318eb83f3897a22816a6943a14.tar.zst
nixlib-83dbb41aed4033318eb83f3897a22816a6943a14.zip
pythonPackages.parse-type: init at 0.3.4
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/parse-type/default.nix38
1 files changed, 38 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/parse-type/default.nix b/pkgs/development/python-modules/parse-type/default.nix
new file mode 100644
index 000000000000..69a02c42b74e
--- /dev/null
+++ b/pkgs/development/python-modules/parse-type/default.nix
@@ -0,0 +1,38 @@
+{ stdenv, fetchPypi, fetchpatch
+, buildPythonPackage, pythonOlder
+, pytest, pytestrunner
+, parse, six, enum34
+}:
+buildPythonPackage rec {
+  pname = "parse-type";
+  version = "0.3.4";
+  name = "${pname}-${version}";
+
+  src = fetchPypi {
+    inherit version;
+    pname = "parse_type";
+    sha256 = "3dd0b323bafcb8c25e000ce5589042a1c99cba9c3bec77b9f591e46bc9606147";
+  };
+
+  patches = [
+    (fetchpatch {
+      name = "python-3.5-tests-compat.patch";
+      url = "https://github.com/jenisys/parse_type/pull/4.patch";
+      sha256 = "1mmn2fxss6q3qhaydd4s4v8vjgvgkg41v1vcivrzdsvgsc3npg7m";
+    })
+  ];
+
+  checkInputs = [ pytest pytestrunner ];
+  propagatedBuildInputs = [ parse six ] ++ stdenv.lib.optional (pythonOlder "3.4") enum34;
+
+  checkPhase = ''
+    py.test tests
+  '';
+
+  meta = with stdenv.lib; {
+    homepage = https://github.com/jenisys/parse_type;
+    description = "Simplifies to build parse types based on the parse module";
+    license = licenses.bsd3;
+    maintainers = with maintainers; [ alunduil ];
+  };
+}