summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorEelco Dolstra <eelco.dolstra@logicblox.com>2007-06-05 16:56:10 +0000
committerEelco Dolstra <eelco.dolstra@logicblox.com>2007-06-05 16:56:10 +0000
commit80c7cce4e9d48b1e9c0f4603ace70191e11292c3 (patch)
tree587ceb21c934d067a0f9fa7c7d1feb2bff75244d /pkgs/development
parente562d4c02139061d6e23f5952a461d12a1a4f010 (diff)
downloadnixlib-80c7cce4e9d48b1e9c0f4603ace70191e11292c3.tar
nixlib-80c7cce4e9d48b1e9c0f4603ace70191e11292c3.tar.gz
nixlib-80c7cce4e9d48b1e9c0f4603ace70191e11292c3.tar.bz2
nixlib-80c7cce4e9d48b1e9c0f4603ace70191e11292c3.tar.lz
nixlib-80c7cce4e9d48b1e9c0f4603ace70191e11292c3.tar.xz
nixlib-80c7cce4e9d48b1e9c0f4603ace70191e11292c3.tar.zst
nixlib-80c7cce4e9d48b1e9c0f4603ace70191e11292c3.zip
* Use /var.
svn path=/nixpkgs/trunk/; revision=8836
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/dbus/default.nix14
1 files changed, 12 insertions, 2 deletions
diff --git a/pkgs/development/libraries/dbus/default.nix b/pkgs/development/libraries/dbus/default.nix
index 587ce5d9c8a1..cd4b8f49e05f 100644
--- a/pkgs/development/libraries/dbus/default.nix
+++ b/pkgs/development/libraries/dbus/default.nix
@@ -7,6 +7,16 @@ stdenv.mkDerivation {
     sha256 = "1jn652zb81mczsx4rdcwrrzj3lfhx9d107zjfnasc4l5yljl204a";
   };
   buildInputs = [pkgconfig expat];
-  configureFlags = "--without-x";
-  #configureFlags = "--localstatedir=/var";
+  configureFlags = "--without-x --localstatedir=/var";
+
+  # Awful hack: `make install' wants to write in /var, but it
+  # can't.  So redirect it with a DESTDIR.
+  preInstall = "
+    installFlagsArray=(DESTDIR=$out/destdir)
+  ";
+
+  postInstall = "
+    mv $out/destdir/$out/* $out
+    rm -rf $out/destdir
+  ";
 }