summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorFlorent Becker <florent.becker@ens-lyon.org>2015-11-15 16:05:01 +0100
committerFlorent Becker <florent.becker@ens-lyon.org>2015-11-15 18:07:48 +0100
commit7ff5826e08430e1d4f27a81c5d3b493a3dfaa0a0 (patch)
tree66c03a5b5b30494ed5875902c1ffba75d2d84d80 /pkgs/development
parent58d870d4b524449f825ca08822a508385c96e2d3 (diff)
downloadnixlib-7ff5826e08430e1d4f27a81c5d3b493a3dfaa0a0.tar
nixlib-7ff5826e08430e1d4f27a81c5d3b493a3dfaa0a0.tar.gz
nixlib-7ff5826e08430e1d4f27a81c5d3b493a3dfaa0a0.tar.bz2
nixlib-7ff5826e08430e1d4f27a81c5d3b493a3dfaa0a0.tar.lz
nixlib-7ff5826e08430e1d4f27a81c5d3b493a3dfaa0a0.tar.xz
nixlib-7ff5826e08430e1d4f27a81c5d3b493a3dfaa0a0.tar.zst
nixlib-7ff5826e08430e1d4f27a81c5d3b493a3dfaa0a0.zip
kcov : init at 29
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/tools/analysis/kcov/default.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/pkgs/development/tools/analysis/kcov/default.nix b/pkgs/development/tools/analysis/kcov/default.nix
new file mode 100644
index 000000000000..d93c64a15a9c
--- /dev/null
+++ b/pkgs/development/tools/analysis/kcov/default.nix
@@ -0,0 +1,30 @@
+{stdenv, fetchurl, cmake, pkgconfig, libelf, zlib, curl, elfutils, python, libiberty, binutils}:
+stdenv.mkDerivation rec {
+  name = "kcov-${version}";
+  version = "29";
+
+  src = fetchurl {
+    url = "https://github.com/SimonKagstrom/kcov/archive/v${version}.tar.gz";
+    sha256 = "0nspf1bfq8zv7zmcmvkbgg3c90k10qcd56gyg8ln5z64nadvha9d";
+  };
+
+  buildInputs = [ cmake pkgconfig libelf zlib curl elfutils python libiberty binutils ];
+  
+  meta = with stdenv.lib; {
+    description = "code coverage tester for compiled programs, Python scripts and shell scripts";
+
+    longDescription =
+      '' Kcov is a code coverage tester for compiled programs, Python
+      scripts and shell scripts. It allows collecting code coverage
+      information from executables without special command-line
+      arguments, and continuosly produces output from long-running
+      applications.
+      '';
+
+    homePage = http://simonkagstrom.github.io/kcov/index.html;
+    license = licenses.gpl2;
+
+    maintainers = [ maintainers.gal_bolle ];
+    };
+    
+  }