summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorRobin Gloster <mail@glob.in>2017-08-01 23:39:33 +0200
committerRobin Gloster <mail@glob.in>2017-08-04 08:26:09 +0200
commit7dc34607641cc8f1815e89340897613c164d3deb (patch)
tree4edf231377583d3e9e0f390186a00072dc92bb3a /pkgs/development
parentf1802d8398f9f08cf165608aa2b43763382acc5f (diff)
downloadnixlib-7dc34607641cc8f1815e89340897613c164d3deb.tar
nixlib-7dc34607641cc8f1815e89340897613c164d3deb.tar.gz
nixlib-7dc34607641cc8f1815e89340897613c164d3deb.tar.bz2
nixlib-7dc34607641cc8f1815e89340897613c164d3deb.tar.lz
nixlib-7dc34607641cc8f1815e89340897613c164d3deb.tar.xz
nixlib-7dc34607641cc8f1815e89340897613c164d3deb.tar.zst
nixlib-7dc34607641cc8f1815e89340897613c164d3deb.zip
wvstreams: remove
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/wvstreams/compile.patch43
-rw-r--r--pkgs/development/libraries/wvstreams/default.nix28
2 files changed, 0 insertions, 71 deletions
diff --git a/pkgs/development/libraries/wvstreams/compile.patch b/pkgs/development/libraries/wvstreams/compile.patch
deleted file mode 100644
index c71e7396e918..000000000000
--- a/pkgs/development/libraries/wvstreams/compile.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-Debian's patch to build with fresher GCC
-
-Index: wvstreams-4.6.1/crypto/wvx509.cc
-===================================================================
---- wvstreams-4.6.1.orig/crypto/wvx509.cc	2011-05-20 00:02:38.119136584 +0200
-+++ wvstreams-4.6.1/crypto/wvx509.cc	2011-05-20 00:02:26.035136589 +0200
-@@ -1157,7 +1157,7 @@
-         
-         if (ext)
-         {
--            X509V3_EXT_METHOD *method = X509V3_EXT_get(ext);
-+            X509V3_EXT_METHOD *method = (X509V3_EXT_METHOD *)X509V3_EXT_get(ext);
-             if (!method)
-             {
-                 WvDynBuf buf;
-Index: wvstreams-4.6.1/ipstreams/wvunixdgsocket.cc
-===================================================================
---- wvstreams-4.6.1.orig/ipstreams/wvunixdgsocket.cc	2011-05-20 00:02:38.391136584 +0200
-+++ wvstreams-4.6.1/ipstreams/wvunixdgsocket.cc	2011-05-20 00:02:35.283136585 +0200
-@@ -1,8 +1,6 @@
- #include "wvunixdgsocket.h"
--#ifdef MACOS
- #include <sys/types.h>
- #include <sys/stat.h>
--#endif
- 
- WvUnixDGSocket::WvUnixDGSocket(WvStringParm filename, bool _server, int perms)
-     : socketfile(filename)
-Index: wvstreams-4.6.1/streams/wvatomicfile.cc
-===================================================================
---- wvstreams-4.6.1.orig/streams/wvatomicfile.cc	2011-05-20 00:02:38.223136584 +0200
-+++ wvstreams-4.6.1/streams/wvatomicfile.cc	2011-05-20 00:02:31.619136587 +0200
-@@ -10,10 +10,7 @@
- #include "wvatomicfile.h"
- #include "wvfileutils.h"
- #include "wvstrutils.h"
--
--#ifdef MACOS
- #include <sys/stat.h>
--#endif
- 
- WvAtomicFile::WvAtomicFile(WvStringParm filename, int flags, mode_t create_mode)
-     : tmp_file(WvString::null)
diff --git a/pkgs/development/libraries/wvstreams/default.nix b/pkgs/development/libraries/wvstreams/default.nix
deleted file mode 100644
index ecfc9b88a0e4..000000000000
--- a/pkgs/development/libraries/wvstreams/default.nix
+++ /dev/null
@@ -1,28 +0,0 @@
-{ stdenv, fetchurl, qt4, dbus, zlib, openssl, readline, perl }:
-
-stdenv.mkDerivation {
-  name = "wvstreams-4.6.1";
-
-  src = fetchurl {
-    url = http://wvstreams.googlecode.com/files/wvstreams-4.6.1.tar.gz;
-    sha256 = "0cvnq3mvh886gmxh0km858aqhx30hpyrfpg1dh6ara9sz3xza0w4";
-  };
-
-  patches = [ ./compile.patch ];
-
-  preConfigure = ''
-    find -type f | xargs sed -i 's@/bin/bash@bash@g'
-
-    sed -e '1i#include <unistd.h>' -i $(find . -name '*.c' -o -name '*.cc')
-  '';
-
-  buildInputs = [ qt4 dbus zlib openssl readline perl ];
-
-  meta = {
-    description = "Network programming library in C++";
-    homepage = http://alumnit.ca/wiki/index.php?page=WvStreams;
-    license = "LGPL";
-    maintainers = [ stdenv.lib.maintainers.marcweber ];
-    platforms = stdenv.lib.platforms.linux;
-  };
-}