summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorMarc Weber <marco-oweber@gmx.de>2009-12-11 13:58:29 +0000
committerMarc Weber <marco-oweber@gmx.de>2009-12-11 13:58:29 +0000
commit78a1418e6d415c6b3ad8d5f61c2bbc91e44629b4 (patch)
treef925913fdad82f19cdfcde5c999a8346d08d63a9 /pkgs/development
parent5d6b65d33975edb36fe7f4a50e19319bf0053fcf (diff)
downloadnixlib-78a1418e6d415c6b3ad8d5f61c2bbc91e44629b4.tar
nixlib-78a1418e6d415c6b3ad8d5f61c2bbc91e44629b4.tar.gz
nixlib-78a1418e6d415c6b3ad8d5f61c2bbc91e44629b4.tar.bz2
nixlib-78a1418e6d415c6b3ad8d5f61c2bbc91e44629b4.tar.lz
nixlib-78a1418e6d415c6b3ad8d5f61c2bbc91e44629b4.tar.xz
nixlib-78a1418e6d415c6b3ad8d5f61c2bbc91e44629b4.tar.zst
nixlib-78a1418e6d415c6b3ad8d5f61c2bbc91e44629b4.zip
ghcs: provide list of core packages. Required by solver of thE haskell-nix-overlay
svn path=/nixpkgs/trunk/; revision=18896
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/compilers/ghc/6.10.1.nix31
-rw-r--r--pkgs/development/compilers/ghc/6.10.2.nix30
-rw-r--r--pkgs/development/compilers/ghc/6.10.3.nix31
-rw-r--r--pkgs/development/compilers/ghc/6.10.4.nix30
-rw-r--r--pkgs/development/compilers/ghc/6.12.1.nix40
5 files changed, 162 insertions, 0 deletions
diff --git a/pkgs/development/compilers/ghc/6.10.1.nix b/pkgs/development/compilers/ghc/6.10.1.nix
index deca9d19f1d2..6d8d6be0d66d 100644
--- a/pkgs/development/compilers/ghc/6.10.1.nix
+++ b/pkgs/development/compilers/ghc/6.10.1.nix
@@ -24,4 +24,35 @@ stdenv.mkDerivation rec {
     inherit homepage;
     description = "The Glasgow Haskell Compiler";
   };
+
+  
+  passthru = {
+    corePackages = [
+      [ "Cabal" "1.6.0.1" ]
+      [ "array" "0.2.0.0" ]
+      [ "base" "3.0.3.0" ]
+      [ "base" "4.0.0.0" ]
+      [ "bytestring" "0.9.1.4" ]
+      [ "containers" "0.2.0.0" ]
+      [ "directory" "1.0.0.2" ]
+      [ "editline" "0.2.1.0" ]
+      [ "filepath" "1.1.0.1" ]
+      [ "(ghc" "6.10.1)" ]
+      [ "ghc-prim" "0.1.0.0" ]
+      [ "haddock" "2.3.0" ]
+      [ "haskell98" "1.0.1.0" ]
+      [ "hpc" "0.5.0.2" ]
+      [ "integer" "0.1.0.0" ]
+      [ "old-locale" "1.0.0.1" ]
+      [ "old-time" "1.0.0.1" ]
+      [ "packedstring" "0.1.0.1" ]
+      [ "pretty" "1.0.1.0" ]
+      [ "process" "1.0.1.0" ]
+      [ "random" "1.0.0.1" ]
+      [ "rts" "1.0" ]
+      [ "syb" "0.1.0.0" ]
+      [ "template-haskell" "2.3.0.0" ]
+      [ "unix" "2.3.1.0" ]
+    ];
+  };
 }
diff --git a/pkgs/development/compilers/ghc/6.10.2.nix b/pkgs/development/compilers/ghc/6.10.2.nix
index 8568c5661450..2b2381fdc93f 100644
--- a/pkgs/development/compilers/ghc/6.10.2.nix
+++ b/pkgs/development/compilers/ghc/6.10.2.nix
@@ -24,4 +24,34 @@ stdenv.mkDerivation rec {
     inherit homepage;
     description = "The Glasgow Haskell Compiler";
   };
+
+  passthru = {
+    corePackages = [
+      [ "Cabal" "1.6.0.3" ]
+      [ "array" "0.2.0.0" ]
+      [ "base" "3.0.3.1" ]
+      [ "base" "4.1.0.0" ]
+      [ "bytestring" "0.9.1.4" ]
+      [ "containers" "0.2.0.1" ]
+      [ "directory" "1.0.0.3" ]
+      [ "editline" "0.2.1.0" ]
+      [ "filepath" "1.1.0.2" ]
+      [ "(ghc" "6.10.2)" ]
+      [ "ghc-prim" "0.1.0.0" ]
+      [ "haddock" "2.4.2" ]
+      [ "haskell98" "1.0.1.0" ]
+      [ "hpc" "0.5.0.3" ]
+      [ "integer" "0.1.0.1" ]
+      [ "old-locale" "1.0.0.1" ]
+      [ "old-time" "1.0.0.2" ]
+      [ "packedstring" "0.1.0.1" ]
+      [ "pretty" "1.0.1.0" ]
+      [ "process" "1.0.1.1" ]
+      [ "random" "1.0.0.1" ]
+      [ "rts" "1.0" ]
+      [ "syb" "0.1.0.1" ]
+      [ "template-haskell" "2.3.0.1" ]
+      [ "unix" "2.3.2.0" ]
+    ];
+  };
 }
diff --git a/pkgs/development/compilers/ghc/6.10.3.nix b/pkgs/development/compilers/ghc/6.10.3.nix
index f05306f1bf90..8b143d06547f 100644
--- a/pkgs/development/compilers/ghc/6.10.3.nix
+++ b/pkgs/development/compilers/ghc/6.10.3.nix
@@ -24,4 +24,35 @@ stdenv.mkDerivation rec {
     inherit homepage;
     description = "The Glasgow Haskell Compiler";
   };
+
+
+  passthru = {
+    corePackages = [
+      [ "Cabal" "1.6.0.3" ]
+      [ "array" "0.2.0.0" ]
+      [ "base" "3.0.3.1" ]
+      [ "base" "4.1.0.0" ]
+      [ "bytestring" "0.9.1.4" ]
+      [ "containers" "0.2.0.1" ]
+      [ "directory" "1.0.0.3" ]
+      [ "extensible-exceptions" "0.1.1.0" ]
+      [ "filepath" "1.1.0.2" ]
+      [ "ghc" "6.10.3" ]
+      [ "ghc-prim" "0.1.0.0" ]
+      [ "haddock" "2.4.2" ]
+      [ "haskell98" "1.0.1.0" ]
+      [ "hpc" "0.5.0.3" ]
+      [ "integer" "0.1.0.1" ]
+      [ "old-locale" "1.0.0.1" ]
+      [ "old-time" "1.0.0.2" ]
+      [ "packedstring" "0.1.0.1" ]
+      [ "pretty" "1.0.1.0" ]
+      [ "process" "1.0.1.1" ]
+      [ "random" "1.0.0.1" ]
+      [ "rts" "1.0" ]
+      [ "syb" "0.1.0.1" ]
+      [ "template-haskell" "2.3.0.1" ]
+      [ "unix" "2.3.2.0" ]
+    ];
+  };
 }
diff --git a/pkgs/development/compilers/ghc/6.10.4.nix b/pkgs/development/compilers/ghc/6.10.4.nix
index 71643a88f0df..75deccb9fc95 100644
--- a/pkgs/development/compilers/ghc/6.10.4.nix
+++ b/pkgs/development/compilers/ghc/6.10.4.nix
@@ -24,4 +24,34 @@ stdenv.mkDerivation rec {
     inherit homepage;
     description = "The Glasgow Haskell Compiler";
   };
+
+  passthru = {
+    corePackages = [
+      [ "Cabal" "1.6.0.3" ]
+      [ "array" "0.2.0.0" ]
+      [ "base" "3.0.3.1" ]
+      [ "base" "4.1.0.0" ]
+      [ "bytestring" "0.9.1.4" ]
+      [ "containers" "0.2.0.1" ]
+      [ "directory" "1.0.0.3" ]
+      [ "extensible-exceptions" "0.1.1.0" ]
+      [ "filepath" "1.1.0.2" ]
+      [ "ghc" "6.10.4" ]
+      [ "ghc-prim" "0.1.0.0" ]
+      [ "haddock" "2.4.2" ]
+      [ "haskell98" "1.0.1.0" ]
+      [ "hpc" "0.5.0.3" ]
+      [ "integer" "0.1.0.1" ]
+      [ "old-locale" "1.0.0.1" ]
+      [ "old-time" "1.0.0.2" ]
+      [ "packedstring" "0.1.0.1" ]
+      [ "pretty" "1.0.1.0" ]
+      [ "process" "1.0.1.1" ]
+      [ "random" "1.0.0.1" ]
+      [ "rts" "1.0" ]
+      [ "syb" "0.1.0.1" ]
+      [ "template-haskell" "2.3.0.1" ]
+      [ "unix" "2.3.2.0" ]
+    ];
+  };
 }
diff --git a/pkgs/development/compilers/ghc/6.12.1.nix b/pkgs/development/compilers/ghc/6.12.1.nix
index 22d7b2a01a04..9b108fbad8a0 100644
--- a/pkgs/development/compilers/ghc/6.12.1.nix
+++ b/pkgs/development/compilers/ghc/6.12.1.nix
@@ -35,4 +35,44 @@ stdenv.mkDerivation rec {
     inherit homepage;
     description = "The Glasgow Haskell Compiler";
   };
+
+
+  passthru = {
+    corePackages = [
+       [ "Cabal" "1.8.0" ]
+       [ "array" "0.3.0.0" ]
+       [ "base" "3.0.3.2" ]
+       [ "base" "4.2.0.0" ]
+       [ "bin-package-db" "0.0.0.0" ]
+       [ "bytestring" "0.9.1.5" ]
+       [ "containers" "0.3.0.0" ]
+       [ "directory" "1.0.1.0" ]
+       [ "dph-base" "0.4.0" ]
+       [ "dph-par" "0.4.0" ]
+       [ "dph-prim-interface" "0.4.0" ]
+       [ "dph-prim-par" "0.4.0" ]
+       [ "dph-prim-seq" "0.4.0" ]
+       [ "dph-seq" "0.4.0" ]
+       [ "extensible-exceptions" "0.1.1.1" ]
+       [ "ffi" "1.0" ]
+       [ "filepath" "1.1.0.3" ]
+       [ "ghc" "6.12.0.20091010" ]
+       [ "ghc-binary" "0.5.0.2" ]
+       [ "ghc-prim" "0.2.0.0" ]
+       [ "haskell98" "1.0.1.1" ]
+       [ "hpc" "0.5.0.4" ]
+       [ "integer-gmp" "0.2.0.0" ]
+       [ "old-locale" "1.0.0.2" ]
+       [ "old-time" "1.0.0.3" ]
+       [ "pretty" "1.0.1.1" ]
+       [ "process" "1.0.1.2" ]
+       [ "random" "1.0.0.2" ]
+       [ "rts" "1.0" ]
+       [ "syb" "0.1.0.2" ]
+       [ "template-haskell" "2.4.0.0" ]
+       [ "time" "1.1.4" ]
+       [ "unix" "2.4.0.0" ]
+       [ "utf8-string" "0.3.4" ]
+    ];
+  };
 }