summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2011-07-01 13:20:12 +0000
committerLudovic Courtès <ludo@gnu.org>2011-07-01 13:20:12 +0000
commit7762934904d6d994bdd70adce6e15398eccf6878 (patch)
tree667651c9b45f42fc02d469c21e12d9d8a32ba151 /pkgs/development
parent3a8af0ddf71b7f36c77ce6768161139eb8487e48 (diff)
downloadnixlib-7762934904d6d994bdd70adce6e15398eccf6878.tar
nixlib-7762934904d6d994bdd70adce6e15398eccf6878.tar.gz
nixlib-7762934904d6d994bdd70adce6e15398eccf6878.tar.bz2
nixlib-7762934904d6d994bdd70adce6e15398eccf6878.tar.lz
nixlib-7762934904d6d994bdd70adce6e15398eccf6878.tar.xz
nixlib-7762934904d6d994bdd70adce6e15398eccf6878.tar.zst
nixlib-7762934904d6d994bdd70adce6e15398eccf6878.zip
BDW-GC, GMP, libffi, libunistring, Readline: Don't use the native `strip'.
Using the native `strip' breaks static libraries when cross-compiling.

svn path=/nixpkgs/trunk/; revision=27572
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/boehm-gc/default.nix9
-rw-r--r--pkgs/development/libraries/gmp/4.nix9
-rw-r--r--pkgs/development/libraries/libffi/default.nix9
-rw-r--r--pkgs/development/libraries/libunistring/default.nix9
-rw-r--r--pkgs/development/libraries/readline/readline6.nix9
5 files changed, 40 insertions, 5 deletions
diff --git a/pkgs/development/libraries/boehm-gc/default.nix b/pkgs/development/libraries/boehm-gc/default.nix
index 6159b99d4438..a5ecc12a8b11 100644
--- a/pkgs/development/libraries/boehm-gc/default.nix
+++ b/pkgs/development/libraries/boehm-gc/default.nix
@@ -1,6 +1,6 @@
 { stdenv, fetchurl }:
 
-stdenv.mkDerivation rec {
+stdenv.mkDerivation (rec {
   name = "boehm-gc-7.2pre20110122";
 
   src = fetchurl {
@@ -41,3 +41,10 @@ stdenv.mkDerivation rec {
     platforms = stdenv.lib.platforms.all;
   };
 }
+
+//
+
+# Don't run the native `strip' when cross-compiling.
+(if (stdenv ? cross)
+ then { dontStrip = true; }
+ else { }))
diff --git a/pkgs/development/libraries/gmp/4.nix b/pkgs/development/libraries/gmp/4.nix
index 9fd5aeff6369..4473e28585d9 100644
--- a/pkgs/development/libraries/gmp/4.nix
+++ b/pkgs/development/libraries/gmp/4.nix
@@ -4,7 +4,7 @@ let
   staticFlags = if static then " --enable-static --disable-shared" else "";
 in
 
-stdenv.mkDerivation rec {
+stdenv.mkDerivation (rec {
   name = "gmp-4.3.2";
 
   src = fetchurl {
@@ -64,3 +64,10 @@ stdenv.mkDerivation rec {
     platforms = stdenv.lib.platforms.all;
   };
 }
+
+//
+
+# Don't run the native `strip' when cross-compiling.
+(if (stdenv ? cross)
+ then { dontStrip = true; }
+ else { }))
diff --git a/pkgs/development/libraries/libffi/default.nix b/pkgs/development/libraries/libffi/default.nix
index 4bf0c05eb285..83f88e1819f9 100644
--- a/pkgs/development/libraries/libffi/default.nix
+++ b/pkgs/development/libraries/libffi/default.nix
@@ -1,6 +1,6 @@
 { fetchurl, stdenv }:
 
-stdenv.mkDerivation rec {
+stdenv.mkDerivation (rec {
   name = "libffi-3.0.9";
 
   src = fetchurl {
@@ -42,3 +42,10 @@ stdenv.mkDerivation rec {
     platforms = stdenv.lib.platforms.all;
   };
 }
+
+//
+
+# Don't run the native `strip' when cross-compiling.
+(if (stdenv ? cross)
+ then { dontStrip = true; }
+ else { }))
diff --git a/pkgs/development/libraries/libunistring/default.nix b/pkgs/development/libraries/libunistring/default.nix
index c7e76447e3fd..590ad64cb40f 100644
--- a/pkgs/development/libraries/libunistring/default.nix
+++ b/pkgs/development/libraries/libunistring/default.nix
@@ -55,4 +55,11 @@ stdenv.mkDerivation (rec {
 # can't find the dll, it will only create a static library.
 (if (stdenv ? glibc)
  then {}
- else { configureFlags = "--with-libiconv-prefix=${libiconv}"; }))
+ else { configureFlags = "--with-libiconv-prefix=${libiconv}"; })
+
+//
+
+# Don't run the native `strip' when cross-compiling.
+(if (stdenv ? cross)
+ then { dontStrip = true; }
+ else { }))
diff --git a/pkgs/development/libraries/readline/readline6.nix b/pkgs/development/libraries/readline/readline6.nix
index 18118abedd98..1bd88069127f 100644
--- a/pkgs/development/libraries/readline/readline6.nix
+++ b/pkgs/development/libraries/readline/readline6.nix
@@ -1,6 +1,6 @@
 { fetchurl, stdenv, ncurses }:
 
-stdenv.mkDerivation rec {
+stdenv.mkDerivation (rec {
   name = "readline-6.1";
 
   src = fetchurl {
@@ -48,3 +48,10 @@ stdenv.mkDerivation rec {
     maintainers = [ stdenv.lib.maintainers.ludo ];
   };
 }
+
+//
+
+# Don't run the native `strip' when cross-compiling.
+(if (stdenv ? cross)
+ then { dontStrip = true; }
+ else { }))