summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorSamuel Leathers <sam@appliedtrust.com>2017-09-15 21:03:51 -0400
committerSamuel Leathers <sam@appliedtrust.com>2017-09-15 21:03:51 -0400
commit755e6eb22e6b8c528006fee70a6bfd3fa352c2c3 (patch)
treea248ff7e4a0e5822e8408c4a4b8dcc373137c1a6 /pkgs/development
parent2edb7e9b2d8ff5db64beb49353353887610d83fb (diff)
downloadnixlib-755e6eb22e6b8c528006fee70a6bfd3fa352c2c3.tar
nixlib-755e6eb22e6b8c528006fee70a6bfd3fa352c2c3.tar.gz
nixlib-755e6eb22e6b8c528006fee70a6bfd3fa352c2c3.tar.bz2
nixlib-755e6eb22e6b8c528006fee70a6bfd3fa352c2c3.tar.lz
nixlib-755e6eb22e6b8c528006fee70a6bfd3fa352c2c3.tar.xz
nixlib-755e6eb22e6b8c528006fee70a6bfd3fa352c2c3.tar.zst
nixlib-755e6eb22e6b8c528006fee70a6bfd3fa352c2c3.zip
hcs_utils: 1.5 -> 2.0
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/hcs_utils/default.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/hcs_utils/default.nix b/pkgs/development/python-modules/hcs_utils/default.nix
new file mode 100644
index 000000000000..785b9ddd04ba
--- /dev/null
+++ b/pkgs/development/python-modules/hcs_utils/default.nix
@@ -0,0 +1,24 @@
+{ stdenv, buildPythonPackage, fetchPypi, six, glibcLocales, pytest }:
+
+buildPythonPackage rec {
+  pname = "hcs_utils";
+  version = "2.0";
+  name  = "${pname}-${version}";
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "04xq69hrys8lf9kp8pva0c4aphjjfw412km7c32ydkwq0i59rhp2";
+  };
+
+  LC_ALL="en_US.UTF-8";
+
+  buildInputs = [ six glibcLocales pytest ];
+
+  meta = with stdenv.lib; {
+    description = "Library collecting some useful snippets";
+    homepage    = https://pypi.python.org/pypi/hcs_utils/1.3;
+    license     = licenses.isc;
+    maintainers = with maintainers; [ lovek323 ];
+    platforms   = platforms.unix;
+  };
+}