summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorVincent Laporte <Vincent.Laporte@gmail.com>2018-05-29 05:27:27 +0000
committerVincent Laporte <Vincent.Laporte@gmail.com>2018-06-06 07:14:26 +0000
commit733d88574b46b666648140c3505f32fc5cc6acec (patch)
tree3708bdb48127363f78da13647f149bb8aacb3ca7 /pkgs/development
parent535a8b000f7f7538de70f8441c56316c51355451 (diff)
downloadnixlib-733d88574b46b666648140c3505f32fc5cc6acec.tar
nixlib-733d88574b46b666648140c3505f32fc5cc6acec.tar.gz
nixlib-733d88574b46b666648140c3505f32fc5cc6acec.tar.bz2
nixlib-733d88574b46b666648140c3505f32fc5cc6acec.tar.lz
nixlib-733d88574b46b666648140c3505f32fc5cc6acec.tar.xz
nixlib-733d88574b46b666648140c3505f32fc5cc6acec.tar.zst
nixlib-733d88574b46b666648140c3505f32fc5cc6acec.zip
ocamlPackages.js-build-tools: use opaline
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/ocaml-modules/janestreet/js-build-tools.nix6
1 files changed, 3 insertions, 3 deletions
diff --git a/pkgs/development/ocaml-modules/janestreet/js-build-tools.nix b/pkgs/development/ocaml-modules/janestreet/js-build-tools.nix
index 2c314f3dbdea..f77b793bcaab 100644
--- a/pkgs/development/ocaml-modules/janestreet/js-build-tools.nix
+++ b/pkgs/development/ocaml-modules/janestreet/js-build-tools.nix
@@ -1,4 +1,4 @@
-{ stdenv, buildOcaml, fetchurl, ocaml_oasis, opam }:
+{ stdenv, buildOcaml, fetchurl, ocaml_oasis, opaline }:
 
 buildOcaml rec {
   name = "js-build-tools";
@@ -13,11 +13,11 @@ buildOcaml rec {
 
   hasSharedObjects = true;
 
-  buildInputs = [ ocaml_oasis opam ];
+  buildInputs = [ ocaml_oasis opaline ];
 
   dontAddPrefix = true;
   configurePhase = "./configure --prefix $prefix";
-  installPhase = "opam-installer -i --prefix $prefix --libdir `ocamlfind printconf destdir` ${name}.install";
+  installPhase = "opaline -prefix $prefix -libdir $OCAMLFIND_DESTDIR ${name}.install";
 
   patches = [ ./js-build-tools-darwin.patch ];