summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorMatthew Maurer <matthew.r.maurer@gmail.com>2016-09-14 15:52:58 -0400
committerMatthew Maurer <matthew.r.maurer@gmail.com>2016-09-14 16:37:20 -0400
commit6f998593a9937027eee317a80a091a46b80bb9b4 (patch)
treeacdd2972e47d33f105c7b059ba89cad9f6c95762 /pkgs/development
parent284c2d8ef55c07c7f87910d0ec1bb2b2bc00fa87 (diff)
downloadnixlib-6f998593a9937027eee317a80a091a46b80bb9b4.tar
nixlib-6f998593a9937027eee317a80a091a46b80bb9b4.tar.gz
nixlib-6f998593a9937027eee317a80a091a46b80bb9b4.tar.bz2
nixlib-6f998593a9937027eee317a80a091a46b80bb9b4.tar.lz
nixlib-6f998593a9937027eee317a80a091a46b80bb9b4.tar.xz
nixlib-6f998593a9937027eee317a80a091a46b80bb9b4.tar.zst
nixlib-6f998593a9937027eee317a80a091a46b80bb9b4.zip
async_kernel: 112.24.00 -> 112.24.00/113.33.03
PPX/P4 split
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/ocaml-modules/async/default.nix4
-rw-r--r--pkgs/development/ocaml-modules/async_extra/default.nix4
-rw-r--r--pkgs/development/ocaml-modules/async_unix/default.nix4
-rw-r--r--pkgs/development/ocaml-modules/janestreet/async-kernel.nix16
4 files changed, 22 insertions, 6 deletions
diff --git a/pkgs/development/ocaml-modules/async/default.nix b/pkgs/development/ocaml-modules/async/default.nix
index 2b84519036c7..2ddfc40b8f86 100644
--- a/pkgs/development/ocaml-modules/async/default.nix
+++ b/pkgs/development/ocaml-modules/async/default.nix
@@ -1,4 +1,4 @@
-{stdenv, buildOcaml, fetchurl, async_kernel,
+{stdenv, buildOcaml, fetchurl, async_kernel_p4,
  async_unix, async_extra, pa_ounit}:
 
 buildOcaml rec {
@@ -12,7 +12,7 @@ buildOcaml rec {
     sha256 = "ecc4ca939ab098e689332921b110dbaacd06d9f8d8bf697023dfff3ca37dc1e9";
   };
 
-  propagatedBuildInputs = [ async_kernel async_unix async_extra pa_ounit ];
+  propagatedBuildInputs = [ async_kernel_p4 async_unix async_extra pa_ounit ];
 
   meta = with stdenv.lib; {
     homepage = https://github.com/janestreet/async;
diff --git a/pkgs/development/ocaml-modules/async_extra/default.nix b/pkgs/development/ocaml-modules/async_extra/default.nix
index 2a6c74f93a78..fbb95a682f4d 100644
--- a/pkgs/development/ocaml-modules/async_extra/default.nix
+++ b/pkgs/development/ocaml-modules/async_extra/default.nix
@@ -1,4 +1,4 @@
-{stdenv, buildOcaml, fetchurl, async_kernel, async_unix,
+{stdenv, buildOcaml, fetchurl, async_kernel_p4, async_unix,
  bin_prot_p4, core_p4, custom_printf, fieldslib_p4, herelib, pa_ounit,
  pipebang, pa_test, sexplib_p4}:
 
@@ -14,7 +14,7 @@ buildOcaml rec {
   };
 
   buildInputs = [ pa_test pa_ounit ];
-  propagatedBuildInputs = [ async_kernel async_unix core_p4 bin_prot_p4 custom_printf
+  propagatedBuildInputs = [ async_kernel_p4 async_unix core_p4 bin_prot_p4 custom_printf
                             fieldslib_p4 herelib pipebang sexplib_p4 ];
 
   meta = with stdenv.lib; {
diff --git a/pkgs/development/ocaml-modules/async_unix/default.nix b/pkgs/development/ocaml-modules/async_unix/default.nix
index 545f7efd85a7..6119bcac876a 100644
--- a/pkgs/development/ocaml-modules/async_unix/default.nix
+++ b/pkgs/development/ocaml-modules/async_unix/default.nix
@@ -1,4 +1,4 @@
-{stdenv, buildOcaml, fetchurl, async_kernel,
+{stdenv, buildOcaml, fetchurl, async_kernel_p4,
  bin_prot_p4, comparelib, core_p4, fieldslib_p4, herelib, pa_ounit,
  pipebang, pa_test, sexplib_p4}:
 
@@ -15,7 +15,7 @@ buildOcaml rec {
 
   hasSharedObjects = true;
   buildInputs = [ pa_ounit ];
-  propagatedBuildInputs = [ async_kernel core_p4 bin_prot_p4 comparelib
+  propagatedBuildInputs = [ async_kernel_p4 core_p4 bin_prot_p4 comparelib
                             fieldslib_p4 herelib pipebang pa_test sexplib_p4 ];
 
    meta = with stdenv.lib; {
diff --git a/pkgs/development/ocaml-modules/janestreet/async-kernel.nix b/pkgs/development/ocaml-modules/janestreet/async-kernel.nix
new file mode 100644
index 000000000000..4d7213a8603e
--- /dev/null
+++ b/pkgs/development/ocaml-modules/janestreet/async-kernel.nix
@@ -0,0 +1,16 @@
+{stdenv, buildOcamlJane, fetchurl, core_kernel,
+ bin_prot, fieldslib,
+ sexplib, herelib, opam, js_build_tools, ocaml_oasis}:
+
+buildOcamlJane rec {
+  name = "async_kernel";
+  hash = "1n6ifbrq6q6hq8bxh6b9vhg11mv9r6jgp1b7vfw7mh5s2nrd4b60";
+  propagatedBuildInputs = [ core_kernel bin_prot fieldslib herelib sexplib ];
+
+  meta = with stdenv.lib; {
+    homepage = https://github.com/janestreet/async_kernel;
+    description = "Jane Street Capital's asynchronous execution library (core) ";
+    license = licenses.asl20;
+    maintainers = [ maintainers.maurer maintainers.ericbmerritt ];
+  };
+}