summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorAnders Kaseorg <andersk@mit.edu>2018-03-03 03:53:52 -0500
committerobadz <obadz-git@obadz.com>2018-03-04 17:28:36 +0000
commit6f073154da086d48d4a3e46a4f5d54698d85ed94 (patch)
treeabc49f727268b9a9a9fa436f3cd08c6e01b6b3f7 /pkgs/development
parent3a094f473aa76937480d563e53886c395fcb1eef (diff)
downloadnixlib-6f073154da086d48d4a3e46a4f5d54698d85ed94.tar
nixlib-6f073154da086d48d4a3e46a4f5d54698d85ed94.tar.gz
nixlib-6f073154da086d48d4a3e46a4f5d54698d85ed94.tar.bz2
nixlib-6f073154da086d48d4a3e46a4f5d54698d85ed94.tar.lz
nixlib-6f073154da086d48d4a3e46a4f5d54698d85ed94.tar.xz
nixlib-6f073154da086d48d4a3e46a4f5d54698d85ed94.tar.zst
nixlib-6f073154da086d48d4a3e46a4f5d54698d85ed94.zip
Give working advice for running nix-prefetch-url
nix-prefetch-url file://… requires a full path.  Suggest an invocation
that will provide one.

Signed-off-by: Anders Kaseorg <andersk@mit.edu>
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/compilers/cudatoolkit/default.nix2
-rw-r--r--pkgs/development/libraries/science/math/cudnn/generic.nix2
-rw-r--r--pkgs/development/libraries/science/math/nccl/generic.nix2
3 files changed, 3 insertions, 3 deletions
diff --git a/pkgs/development/compilers/cudatoolkit/default.nix b/pkgs/development/compilers/cudatoolkit/default.nix
index 8f9f6e19993d..d569e2401b6d 100644
--- a/pkgs/development/compilers/cudatoolkit/default.nix
+++ b/pkgs/development/compilers/cudatoolkit/default.nix
@@ -28,7 +28,7 @@ let
               This nix expression requires that ${args.name} is already part of the store.
               Register yourself to NVIDIA Accelerated Computing Developer Program, retrieve the CUDA toolkit
               at https://developer.nvidia.com/cuda-toolkit, and run the following command in the download directory:
-              nix-prefetch-url file://${args.name}
+              nix-prefetch-url file://\$PWD/${args.name}
             '';
             inherit (args) name sha256;
           }
diff --git a/pkgs/development/libraries/science/math/cudnn/generic.nix b/pkgs/development/libraries/science/math/cudnn/generic.nix
index 663b741e4748..51bda19cf139 100644
--- a/pkgs/development/libraries/science/math/cudnn/generic.nix
+++ b/pkgs/development/libraries/science/math/cudnn/generic.nix
@@ -21,7 +21,7 @@ stdenv.mkDerivation rec {
       This nix expression requires that ${name} is already part of the store.
       Register yourself to NVIDIA Accelerated Computing Developer Program, retrieve the cuDNN library
       at https://developer.nvidia.com/cudnn, and run the following command in the download directory:
-      nix-prefetch-url file://${name}
+      nix-prefetch-url file://\$PWD/${name}
     '';
   };
 
diff --git a/pkgs/development/libraries/science/math/nccl/generic.nix b/pkgs/development/libraries/science/math/nccl/generic.nix
index aa04d75b078b..609a7df51e58 100644
--- a/pkgs/development/libraries/science/math/nccl/generic.nix
+++ b/pkgs/development/libraries/science/math/nccl/generic.nix
@@ -21,7 +21,7 @@ stdenv.mkDerivation rec {
       This nix expression requires that ${name} is already part of the store.
       Register yourself to NVIDIA Accelerated Computing Developer Program, retrieve the NCCL library
       at https://developer.nvidia.com/nccl, and run the following command in the download directory:
-      nix-prefetch-url file://${name}
+      nix-prefetch-url file://\$PWD/${name}
     '';
   };