summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authormingchuan <ming@culpring.com>2016-12-21 16:23:01 +0800
committermingchuan <ming@culpring.com>2016-12-25 01:14:19 +0800
commit6db2c983c1d7b2fb994c18b91ce9ed381d4053f4 (patch)
tree99de5106f5be0aca8ce17d8311cfe0a9780af531 /pkgs/development
parent790818540081420d30a5a04cd8cb4c823c711fee (diff)
downloadnixlib-6db2c983c1d7b2fb994c18b91ce9ed381d4053f4.tar
nixlib-6db2c983c1d7b2fb994c18b91ce9ed381d4053f4.tar.gz
nixlib-6db2c983c1d7b2fb994c18b91ce9ed381d4053f4.tar.bz2
nixlib-6db2c983c1d7b2fb994c18b91ce9ed381d4053f4.tar.lz
nixlib-6db2c983c1d7b2fb994c18b91ce9ed381d4053f4.tar.xz
nixlib-6db2c983c1d7b2fb994c18b91ce9ed381d4053f4.tar.zst
nixlib-6db2c983c1d7b2fb994c18b91ce9ed381d4053f4.zip
shards: init at 0.7.1
Dependency manager for the Crystal language
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/tools/build-managers/shards/default.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/pkgs/development/tools/build-managers/shards/default.nix b/pkgs/development/tools/build-managers/shards/default.nix
new file mode 100644
index 000000000000..7db0d89e8b1f
--- /dev/null
+++ b/pkgs/development/tools/build-managers/shards/default.nix
@@ -0,0 +1,28 @@
+{ stdenv, fetchurl, crystal, libyaml, which }:
+
+stdenv.mkDerivation rec {
+  name = "shards-${version}";
+  version = "0.7.1";
+
+  src = fetchurl {
+    url = "https://github.com/crystal-lang/shards/archive/v${version}.tar.gz";
+    sha256 = "31de819c66518479682ec781a39ef42c157a1a8e6e865544194534e2567cb110";
+  };
+
+  buildInputs = [ crystal libyaml which ];
+
+  buildFlags = [ "CRFLAGS=" "release" ];
+
+  installPhase = ''
+    mkdir -p $out/bin
+    cp bin/shards $out/bin/
+  '';
+
+  meta = with stdenv.lib; {
+    homepage = "https://crystal-lang.org/";
+    license = licenses.asl20;
+    description = "Dependency manager for the Crystal language";
+    maintainers = with maintainers; [ mingchuan ];
+    platforms = [ "x86_64-linux" "i686-linux" "x86_64-darwin" ];
+  };
+}