summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorTuomas Tynkkynen <tuomas@tuxera.com>2016-07-06 01:19:01 +0300
committerTuomas Tynkkynen <tuomas@tuxera.com>2016-07-06 01:19:01 +0300
commit6d16ececdd4c59437c7a6db7ab1cb030e24d627e (patch)
tree2916c9c93a868af02eb00cf57ec5018304a46c24 /pkgs/development
parente12f789cef22fc7d4924c2acae7d805e7f39562a (diff)
parent2cf8cb7f46b08eb0a547243742711b3e88b63d12 (diff)
downloadnixlib-6d16ececdd4c59437c7a6db7ab1cb030e24d627e.tar
nixlib-6d16ececdd4c59437c7a6db7ab1cb030e24d627e.tar.gz
nixlib-6d16ececdd4c59437c7a6db7ab1cb030e24d627e.tar.bz2
nixlib-6d16ececdd4c59437c7a6db7ab1cb030e24d627e.tar.lz
nixlib-6d16ececdd4c59437c7a6db7ab1cb030e24d627e.tar.xz
nixlib-6d16ececdd4c59437c7a6db7ab1cb030e24d627e.tar.zst
nixlib-6d16ececdd4c59437c7a6db7ab1cb030e24d627e.zip
Merge remote-tracking branch 'upstream/staging' into master
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/interpreters/python/2.7/default.nix9
-rw-r--r--pkgs/development/interpreters/python/2.7/no-ldconfig.patch97
2 files changed, 106 insertions, 0 deletions
diff --git a/pkgs/development/interpreters/python/2.7/default.nix b/pkgs/development/interpreters/python/2.7/default.nix
index ebd9dba1ce32..e47fc82f4e8e 100644
--- a/pkgs/development/interpreters/python/2.7/default.nix
+++ b/pkgs/development/interpreters/python/2.7/default.nix
@@ -44,6 +44,15 @@ let
       ./deterministic-build.patch
 
       ./properly-detect-curses.patch
+    ] ++ optionals stdenv.isLinux [
+
+      # Disable the use of ldconfig in ctypes.util.find_library (since
+      # ldconfig doesn't work on NixOS), and don't use
+      # ctypes.util.find_library during the loading of the uuid module
+      # (since it will do a futile invocation of gcc (!) to find
+      # libuuid, slowing down program startup a lot).
+      ./no-ldconfig.patch
+
     ] ++ optionals stdenv.isCygwin [
       ./2.5.2-ctypes-util-find_library.patch
       ./2.5.2-tkinter-x11.patch
diff --git a/pkgs/development/interpreters/python/2.7/no-ldconfig.patch b/pkgs/development/interpreters/python/2.7/no-ldconfig.patch
new file mode 100644
index 000000000000..10284c7b3744
--- /dev/null
+++ b/pkgs/development/interpreters/python/2.7/no-ldconfig.patch
@@ -0,0 +1,97 @@
+diff -ru -x '*~' Python-2.7.11-orig/Lib/ctypes/util.py Python-2.7.11/Lib/ctypes/util.py
+--- Python-2.7.11-orig/Lib/ctypes/util.py	2015-12-05 20:46:56.000000000 +0100
++++ Python-2.7.11/Lib/ctypes/util.py	2016-07-01 14:24:50.714223450 +0200
+@@ -212,31 +212,7 @@
+     else:
+ 
+         def _findSoname_ldconfig(name):
+-            import struct
+-            if struct.calcsize('l') == 4:
+-                machine = os.uname()[4] + '-32'
+-            else:
+-                machine = os.uname()[4] + '-64'
+-            mach_map = {
+-                'x86_64-64': 'libc6,x86-64',
+-                'ppc64-64': 'libc6,64bit',
+-                'sparc64-64': 'libc6,64bit',
+-                's390x-64': 'libc6,64bit',
+-                'ia64-64': 'libc6,IA-64',
+-                }
+-            abi_type = mach_map.get(machine, 'libc6')
+-
+-            # XXX assuming GLIBC's ldconfig (with option -p)
+-            expr = r'\s+(lib%s\.[^\s]+)\s+\(%s' % (re.escape(name), abi_type)
+-            f = os.popen('/sbin/ldconfig -p 2>/dev/null')
+-            try:
+-                data = f.read()
+-            finally:
+-                f.close()
+-            res = re.search(expr, data)
+-            if not res:
+-                return None
+-            return res.group(1)
++            return None
+ 
+         def find_library(name):
+             return _findSoname_ldconfig(name) or _get_soname(_findLib_gcc(name))
+diff -ru -x '*~' Python-2.7.11-orig/Lib/uuid.py Python-2.7.11/Lib/uuid.py
+--- Python-2.7.11-orig/Lib/uuid.py	2015-12-05 20:47:09.000000000 +0100
++++ Python-2.7.11/Lib/uuid.py	2016-07-01 14:33:14.360446897 +0200
+@@ -437,57 +437,7 @@
+         return ((bytes[0]<<40L) + (bytes[1]<<32L) + (bytes[2]<<24L) +
+                 (bytes[3]<<16L) + (bytes[4]<<8L) + bytes[5])
+ 
+-# Thanks to Thomas Heller for ctypes and for his help with its use here.
+-
+-# If ctypes is available, use it to find system routines for UUID generation.
+ _uuid_generate_time = _UuidCreate = None
+-try:
+-    import ctypes, ctypes.util
+-    import sys
+-
+-    # The uuid_generate_* routines are provided by libuuid on at least
+-    # Linux and FreeBSD, and provided by libc on Mac OS X.
+-    _libnames = ['uuid']
+-    if not sys.platform.startswith('win'):
+-        _libnames.append('c')
+-    for libname in _libnames:
+-        try:
+-            lib = ctypes.CDLL(ctypes.util.find_library(libname))
+-        except:
+-            continue
+-        if hasattr(lib, 'uuid_generate_time'):
+-            _uuid_generate_time = lib.uuid_generate_time
+-            break
+-    del _libnames
+-
+-    # The uuid_generate_* functions are broken on MacOS X 10.5, as noted
+-    # in issue #8621 the function generates the same sequence of values
+-    # in the parent process and all children created using fork (unless
+-    # those children use exec as well).
+-    #
+-    # Assume that the uuid_generate functions are broken from 10.5 onward,
+-    # the test can be adjusted when a later version is fixed.
+-    if sys.platform == 'darwin':
+-        import os
+-        if int(os.uname()[2].split('.')[0]) >= 9:
+-            _uuid_generate_time = None
+-
+-    # On Windows prior to 2000, UuidCreate gives a UUID containing the
+-    # hardware address.  On Windows 2000 and later, UuidCreate makes a
+-    # random UUID and UuidCreateSequential gives a UUID containing the
+-    # hardware address.  These routines are provided by the RPC runtime.
+-    # NOTE:  at least on Tim's WinXP Pro SP2 desktop box, while the last
+-    # 6 bytes returned by UuidCreateSequential are fixed, they don't appear
+-    # to bear any relationship to the MAC address of any network device
+-    # on the box.
+-    try:
+-        lib = ctypes.windll.rpcrt4
+-    except:
+-        lib = None
+-    _UuidCreate = getattr(lib, 'UuidCreateSequential',
+-                          getattr(lib, 'UuidCreate', None))
+-except:
+-    pass
+ 
+ def _unixdll_getnode():
+     """Get the hardware address on Unix using ctypes."""