summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorRichard Marko <srk@48.io>2018-02-01 22:31:14 +0100
committerRichard Marko <srk@48.io>2018-02-03 09:55:08 +0100
commit6c52f36468d2d273397082b60b708cf2693b0897 (patch)
tree38701abc5602ab541d43b459c40ee29b19f071a4 /pkgs/development
parent096a07f5e274c2cfdcdb5c9b26d347517d5419ef (diff)
downloadnixlib-6c52f36468d2d273397082b60b708cf2693b0897.tar
nixlib-6c52f36468d2d273397082b60b708cf2693b0897.tar.gz
nixlib-6c52f36468d2d273397082b60b708cf2693b0897.tar.bz2
nixlib-6c52f36468d2d273397082b60b708cf2693b0897.tar.lz
nixlib-6c52f36468d2d273397082b60b708cf2693b0897.tar.xz
nixlib-6c52f36468d2d273397082b60b708cf2693b0897.tar.zst
nixlib-6c52f36468d2d273397082b60b708cf2693b0897.zip
python-canmatrix: init at 0.6
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/canmatrix/default.nix46
1 files changed, 46 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/canmatrix/default.nix b/pkgs/development/python-modules/canmatrix/default.nix
new file mode 100644
index 000000000000..99ac6c3ec45b
--- /dev/null
+++ b/pkgs/development/python-modules/canmatrix/default.nix
@@ -0,0 +1,46 @@
+{ lib
+, stdenv
+, buildPythonPackage
+, fetchFromGitHub
+, python
+, lxml
+, xlwt
+, xlrd
+, XlsxWriter
+, pyyaml
+, future }:
+
+buildPythonPackage rec {
+  pname = "canmatrix";
+  version = "0.6";
+
+  # uses fetchFromGitHub as PyPi release misses test/ dir
+  src = fetchFromGitHub {
+    owner = "ebroecker";
+    repo = pname;
+    rev = version;
+    sha256 = "1lb0krhchja2jqfsh5lsfgmqcchs1pd38akvc407jfmll96f4yqz";
+  };
+
+  checkPhase = ''
+    cd test
+    ${python.interpreter} ./test.py
+  '';
+
+  propagatedBuildInputs =
+    [ lxml
+      xlwt
+      xlrd
+      XlsxWriter
+      pyyaml
+      future
+    ];
+
+  meta = with lib; {
+    homepage = https://github.com/ebroecker/canmatrix;
+    description = "Support and convert several CAN (Controller Area Network) database formats .arxml .dbc .dbf .kcd .sym fibex xls(x)";
+    license = licenses.bsd2;
+    maintainers = with maintainers; [ sorki ];
+  };
+}
+