summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorWilliam A. Kennington III <william@wkennington.com>2014-09-14 16:01:38 -0700
committerWilliam A. Kennington III <william@wkennington.com>2014-09-21 15:18:16 -0700
commit698dfe11a3710ae9dc98ad983309771b9aa4eeb5 (patch)
tree6aae3030c6eb956fa677fb29c94994323b02c2f8 /pkgs/development
parent0f7c7279d28b46b836094805671c2142336add8f (diff)
downloadnixlib-698dfe11a3710ae9dc98ad983309771b9aa4eeb5.tar
nixlib-698dfe11a3710ae9dc98ad983309771b9aa4eeb5.tar.gz
nixlib-698dfe11a3710ae9dc98ad983309771b9aa4eeb5.tar.bz2
nixlib-698dfe11a3710ae9dc98ad983309771b9aa4eeb5.tar.lz
nixlib-698dfe11a3710ae9dc98ad983309771b9aa4eeb5.tar.xz
nixlib-698dfe11a3710ae9dc98ad983309771b9aa4eeb5.tar.zst
nixlib-698dfe11a3710ae9dc98ad983309771b9aa4eeb5.zip
libyamlcpp: Correct meta information and boost
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/libraries/libyaml-cpp/default.nix10
1 files changed, 6 insertions, 4 deletions
diff --git a/pkgs/development/libraries/libyaml-cpp/default.nix b/pkgs/development/libraries/libyaml-cpp/default.nix
index fb81dc425f1f..1ba31a7a6d52 100644
--- a/pkgs/development/libraries/libyaml-cpp/default.nix
+++ b/pkgs/development/libraries/libyaml-cpp/default.nix
@@ -1,4 +1,4 @@
-{stdenv, fetchurl, cmake, boostHeaders}:
+{ stdenv, fetchurl, cmake, boost }:
 
 stdenv.mkDerivation {
   name = "libyaml-cpp-0.5.1";
@@ -8,11 +8,13 @@ stdenv.mkDerivation {
     sha256 = "01kg0h8ksp162kdhyzn67vnlxpj5zjbks84sh50pv61xni990z1y";
   };
 
-  buildInputs = [ cmake boostHeaders ];
+  buildInputs = [ cmake boost ];
 
-  meta = {
+  meta = with stdenv.lib; {
     homepage = http://code.google.com/p/yaml-cpp/;
     description = "A YAML parser and emitter for C++";
-    license = stdenv.lib.licenses.mit;
+    license = licenses.mit;
+    platforms = platforms.unix;
+    maintainers = with maintainers; [ wkennington ];
   };
 }