summary refs log tree commit diff
path: root/pkgs/development
diff options
context:
space:
mode:
authorJörg Thalheim <Mic92@users.noreply.github.com>2017-10-15 18:06:40 +0100
committerGitHub <noreply@github.com>2017-10-15 18:06:40 +0100
commit69886a41706306e4bf27c9f2ae5c5e13493e5971 (patch)
tree8d997ceac999c8bd256566c5d089000c5e5e9d17 /pkgs/development
parent58350ad44a9757922cb4676e36eb906e67affaa7 (diff)
parent4b8aa5bd4c3de03e0d0ba76853f80ec341460476 (diff)
downloadnixlib-69886a41706306e4bf27c9f2ae5c5e13493e5971.tar
nixlib-69886a41706306e4bf27c9f2ae5c5e13493e5971.tar.gz
nixlib-69886a41706306e4bf27c9f2ae5c5e13493e5971.tar.bz2
nixlib-69886a41706306e4bf27c9f2ae5c5e13493e5971.tar.lz
nixlib-69886a41706306e4bf27c9f2ae5c5e13493e5971.tar.xz
nixlib-69886a41706306e4bf27c9f2ae5c5e13493e5971.tar.zst
nixlib-69886a41706306e4bf27c9f2ae5c5e13493e5971.zip
Merge pull request #29819 from Moredread/mechanicalsoup-0.7.0
pythonPackages.MechanicalSoup: 0.4.0 -> 0.7.0
Diffstat (limited to 'pkgs/development')
-rw-r--r--pkgs/development/python-modules/MechanicalSoup/default.nix23
1 files changed, 23 insertions, 0 deletions
diff --git a/pkgs/development/python-modules/MechanicalSoup/default.nix b/pkgs/development/python-modules/MechanicalSoup/default.nix
new file mode 100644
index 000000000000..a022fd9fc410
--- /dev/null
+++ b/pkgs/development/python-modules/MechanicalSoup/default.nix
@@ -0,0 +1,23 @@
+{ fetchPypi, buildPythonPackage, lib
+, requests, beautifulsoup4, six }:
+
+
+buildPythonPackage rec {
+  name = "${pname}-${version}";
+  pname = "MechanicalSoup";
+  version = "0.7.0";
+
+  src = fetchPypi {
+    inherit pname version;
+    sha256 = "0wh93rml446ipx603n5z5i5bpan46pzliq6sw76d0ms9w7w2658d";
+  };
+
+  propagatedBuildInputs = [ requests beautifulsoup4 six ];
+
+  meta = with lib; {
+    description = "A Python library for automating interaction with websites";
+    homepage = https://github.com/hickford/MechanicalSoup;
+    license = licenses.mit;
+    maintainers = [ maintainers.jgillich ];
+  };
+}